OpenMV IDE v2.8.1 on Windows 10 (Portenta H7)


I can not get the OpenMV IDE to connect properly to my Portenta H7. If it is able to connect, I get offered the chance to update the firmware, which is already up to date. Once in a while, I can get a script to run, but it only seems to run a loop once. The IDE does not seem to know what a Portenta H7 is, and seems to just be looking for, and expecting, an OpenMV Cam.

I am trying to reload Micropython now, but it is exiting with an error code of 74. I have the Portenta H7 in DFU mode before I start the IDE. I have also tried switching it to DFU mode after starting the IDE. It looks to me like the IDE does not know it is a Portenta H7 it is trying to connect to. It does not identify the board and only mentions OpenMV Cam in all dialogs.

Am I doing something wrong? It works great with Arduino code on both cores.


You need to put the board in bootloader mode by double clicking the reset button. After you do this the IDE can load our firmware and then it should be fine to use.

I already tried putting it into DFU mode before loading the IDE but that did not help. I will give it another try because I really want to run Micropython on this board.


OK, I put it into bootloader mode before I started the IDE. It does execute the current script. If I change I have to manually reset the board before the new version gets executed.

This is the behavior I see now.

Next, I will try running one of the canned examples but if I have to reset the board to run it, it will disconnect from the IDE,


See if the latest firmware fixes your issue.

It did not fix anything. :frowning: Also, I could not get rshell to connect with the Portenta H7’s REPL.


Also, when I am in the Portenta REPL, Ctrl-D does not restart the current script ( This is a problem now because I know I am getting an error in my script but have no way to see what is wrong.


Hi, um, how are you connecting to REPL? Via the IDE’s open terminal feature?

@iabdalkader Any thoughts?

No. I connect using screen on Linux. It works fine with all my other boards. This is part of my usual Linux workflow. I can not do anything useful using the OpenMV IDE with the Portenta H7 right now.


Ctrl-D does not restart, it only runs once on first boot. Ctrl-D does a soft-reset.

@hybotics If you’re having any issues please post specific steps to reproduce the issue, include any scripts, files that I need to be able to reproduce the issue.

You can just run your script in the IDE and see what/where the error is.