OpenMV-V2 Prototype: IDE V1.3 Firmware Issue


Just wanted to note that the OpenMV V1.3 IDE cannot upload any firmware to the OpenMV V2, and seems to be incompatible with its own firmware release.

Just to note, that there is no physical issue or hard fault with the board - I get a flashing blue “heartbeat”. When I try to connect, after verifying that I have selected the correct COM port, baud rate and board type, the IDE presents the following error message:

So I proceed to use the built-in firmware upload utility. It (and preferences) are the only two available options, as the rest are grayed out.

For some odd reason, the firmware update utility doesn’t like .DFU files, and instead, only accepts .bin files. The utility clearly points out the .DFU file extension selection option at the bottom. I went ahead and hit ‘open’, and when I hit ‘OK’, the IDE did nothing but hang.

I also tried to upload firmware to the STM32 on the sensor using STMicroelectronic’s DfuSe Demo. I had tried both the V2 .DFU in the V1.3 release, as well as the V2 .DFU in the openmv-master zip from the Github page. Both did not work with the new V1.3 IDE (Or even the V1.2 IDE for that matter). I guess I’m stuck using the V1.1 release IDE and firmware (which doesn’t have a firmware utility/update prompt).

Has anyone gotten the OpenMV-V2 sensor to work with the V1.3 IDE/scripts? If the V1.1 release works fine, will the newer releases of code for things like object detection, facial detection, or FAST/FREAK work with the old IDE? Or could it be that I’m using the wrong method of uploading new firmware. Any help would be appreciated!


  • Ian

About to get on a flight. So, I can’t go in detail. But, Google micropython on Windows. There’s a guide that shows how to DFU update. Basically, you can only firmware update on Linux right now. Ibrahim is working on a bootloader to fix this issue.

I heavily recommend installing the Linux development environment until we get everything to the release state. Please see the OpenMV wiki on the github repo for how to do that.


The board you have shipped with an older firmware, and you have a newer IDE, so you just need to update the firmware image.
The IDE was recently updated to support updating older firmware instead of not connecting at all…

Re the DFU issue, the IDE bootloader is not supported on Windows (libusb issues), you have to upload the firmware manually, using DfuSe.

To fix this issue we’re working on a new bootloader that will support on all platforms.

Thanks guys, I appreciate the help. I’ll look into working on a Linux environment.