Major issues with OpenMV IDE 4.0.1 on Windows

I seem to be stuck in some kind of an endless upgrade loop with this. It seemed to work OK, but I attempted to update the firmware on my H7 and it failed, and seems to have bricked the device. When trying to reinstall firmware, it erases OK but hangs at 6% programming (the green light on the device is still blinking though)

Also, closing and reopening the IDE then prompts again for reinstalling the 4.0.1 update.

HELP!

Hi,
Had exactly the same issue and same behaviour with my H7 (H7 Plus worked fine) on my desktop machine with lots and lots of USB stuff connected to.
I installed the IDE on a notebook and connected only the H7, nothing else, then the normal firmware update process worked fine.
If you have any other machine I’d give that a try with only the H7 connected.

Felix

Hi, the IDE will try fast mode to load firmware and then fallback on a slow mode to load if that fails. Please do not kill the dialog if it hangs. It should switch to the slow mode in 10 seconds.

It never switched, even after a few minutes.

Can you post a video of what is happening? I can issue IDE updates quickly so I may be able to fix this quickly.

Just to follow up, the latest version of the installer works perfectly, as does the firmware updater. Thanks!