Cannot upgrade H7 plus firmwmare

I’m having troubles getting my openmv h7 plus firmware upgraded from Linux environment
I tried to upgrade the firmware using IDE, which didn’t work, so I also tried using a separate openmv4p firmware.bin from github, but it didn’t work as well. They were basically loading forever
I also tried using DFU, but for some reason (maybe I’m doing something wrong), it’s not doing anything to the device
In this case, how should I upgrade my firmware?

We’re you able to connect to the camera via the serial port? If so there should be no issue to update the firmware.

Yes, I have no problem using the camera through openmv IDE. it’s the firmware that’s not upgrading for some reason. But whenever i try to upgrade the firmware, it shows the tab with blue bar fully loaded, and it just stays like that forever

Can you post a gif/video? Or a screen shot on where it gets stuck. If the IDE works at all then this shouldn’t be an issue as we don’t depend on any special drivers except serial port access - which already works if you can use the IDE at all.

This is what shows up as soon as I try to update. It starts with fully loaded bar, and just stays like this forever. The current version of firmware that I have is 4.2.0

Are you using a VM?

The issue here is that the serial port is disappeared on your linux machine. If you have a VM and then it moved onto the host system the IDE cannot find it anymore.

Oh, i see. Yes, i am using VM. Is there a way to resolve this issue?

Yeah, you need to move the device back to the VM when programming starts if the host took control of it.

So, just go to USB devices and assign the bootloader device back to the VM.