It does not focus with Ultra Wide Angle Lens


Thank you for this project! We are proud owners of two OpenMV M7 Cams.

I had the honor of participating in the OpenMV H7 cam kickstarter… and this week i received the package with the OpenMV H7 Cam + other accesories/items :smiley: Today (2010/05/19) I have begun to test all the new material.

First: The cam seems works! :mrgreen:

However i have problems with any items (LCD Shield, Wifi Shield, Ultra Wide Angle Lens) . :unamused:

In this post i will only describe my problem about the Ultra Wide Angle Lens:


I am unable to focus with the Ultra Wide Angle Lens. I have no problem with telephoto lens or normal lens. However I have to screw the lens a lot to start focusing. And then, when i am starting to focus I think I have reached the limit, and I do not want to force more. It is too hard. Effectively. I perceive the wide angle (in the Frame Buffer Screen) but too unfocused to distinguish details. :frowning:

Any help or hint?

If you need more info (pictures or so), just ask for it!

Thanks in advance!


My environment is Windows 10 x64. OpenMV IDE 2.2.0 The firmware is 3.4.1 (i have upgraded).

Hi, yes please post pictures of the lens, framebuffer etc… Also please post all the issues with you have with anything else in this post.

I just check my OpenMV H7 wide angle lens and have the same problem (the std lens is working fine). I tried cleaning the thread on the lens with IPA, then screwing in and repeating several time, but its made no difference. The photo of the lens shows the position where it stopped turning. As far as I can see both threads look fine and the bottom of the lens will be nowhere near the camera chip.


Hi, you need to loosen this screw a little bit:

I took the screw out, it gets a bit further, but still not in focus.


I’m not sure it could be the lens, I’ll contact our supplier and get back to you. @jcarlos are you having the same issue if you remove the screw ?

It would be helpful if someone can measure the inner diameter of the mount and the diameter of the lens to compare.

In the meantime if you want a replacement lens mount just order another one from the store and add a note to the order and I’ll refund it.

Measured with caliper gauge.

Lens, I get 11.86/11.87mm anywhere on the thread, does not seem to be tapered.
Base, I get 11.44mm from an avg of 6 measurements, this is harder measure accurately. Despite repeated measurements I could not convince my self was tapered, but maybe my caliper skills are not up to this!


Almost the same here, but mine works fine. Anyway I’ll forward this to our supplier, thanks for taking the time to measure it. Please order a lens mount from the store and leave a note.

Ordered lens mount as requested, its Order 3919.


Sorry for my delayed answer!

Are you sure? they are very different problems… I though it was better open new posts for each problem…

Well. I have removed the screw completely, and it certainly seems that I can go a little further. It is better however it is not enough. :confused:


I attach a video where you can see the full procedure and framebuffer:

NOTE 1: The screw is removed.
NOTE 2: I have verified carefully that I have not overcome the best point of focus at any time.

Please; if you need pictures, just ask me.


Sorry for my English!

It looks like a problem with some lens mounts, I’ll have more details later. For now all I can do is send you a replacement, please order another lens mount and I’ll refund. As for the other issues, please search the forums first for issues related to LCD or WiFi shields, if nothing helps go ahead and post in new posts.

Hi, some of our lenses mounts are sometimes not perfectly constructed. So, we need to send you a replacement one. Please email us about getting a replacement lens mount.

I have the same problem. The new H7 lens mount seems a lot tighter than the M7. With the normal lens the friction is “just right”. But the wide angle lens the thread is too tight to get a normal focus.

I will tell our CM to check the wide angle lens fits on all new units.

I just used a dremel to remove half of the thread and it is good now :laughing:
Lens holder thread removed.jpg

I received the new lens mount and can confirm the wide angle lens now focuses perfectly. Thankyou.

I think that it is a known issue that some of the lens mounts cannot accommodate the ultra wide lens. You can screw it in most of the way, but not enough to get proper focus. The replacement mounts they sell for $1 apiece seem to work fine.