IDE -- missing frame buffer view and histos

Hi, I have just got my fresh new openmv cam m7 and installed the IDE on my mac. Unfortunately, I can’t find the way to open the frame buffer and the histos (please see attachment). I don’t find the drawer either on the right side. I use IDE v1.6.0 on osx 10.8.5 (I know it is rather old…) Could You please take a look?


This issue was fixed in 1.6.0, see:

I’m not sure if it was tested on Mac though, do you see those drawers in the IDE ?


Well, it seems to be missing…

This was tested on a Mac… Wtf. Um, anyway, just hover you mouse near the edge of the IDE and it should change to indicate a drawer you can grab. Click and draw to unhide the drawer.

Hi, I tried to hover the mouse to the edge, but nothing happens. Yesterday we tried the same version on Windows and it works well. I will try it today on a different OSX version and will report. Is there any component that should be installed? I mean that is usually there, but missing from mine (even if it is not a hacked operating system)?

Works on my mac… weird.

Um, try deleting the OpenMV IDE settings. “/home//.config/OpenMVIDE” just wipe that folder out and OpenMV IDE should re-create it. Maybe there’s some junk in there.

We have just checked it on OSX 10.10 and it works there… Strange. Might there be any dependency?


No, there shouldn’t be. All that code is part of the core of Qt.

Hi all,

I just got my OpenMV Cam this weekend and I had the same issue on Ubuntu.

I tried dragging left from the right top corner of the IDE and the Frame Buffer view magically appeared. :smiley:


Well, I tried this dragging, but for me the framebuffer and the histos didn’t show up. I also tried to restart the machine (yes, even a mac needs it sometimes, too), but negative. Reinstalled the software, but this didn’t help either.


Mmm, I want to fit this but I have no way to determine the error condition… did you delete the user settings folder? .config/OpenMV IDE? That’s the only thing that would influence this…

Hi, it becomes even more strange. I removed the OpenMVIDE.ini. Then when I started the application the framebuffer and the histos showed up! (the drawer however was missing). I could connect the camera and still saw the live image. However, at the next start the problem appeared again. I attached the copy of the .ini file at various stages (I’m afraid I had to change the extension otherwise I couldn’t attach them). OpenMVIDE_ini_firstStart is the file right after deleting the old .ini file and starting the software. At this stage no camera is connected, but the framebuffer and the histos are shown. Next file is OpenMVIDE_ini_cameraConnected when the camera is connected and the live image is seen in the framebuffer window. Then the software is terminated and the OpenMVIDE_ini_sfterExit file is recorded. At the new start (OpenMVIDE_ini_nextStart) however no framebuffer and histos show up. When looking at the files one might have the impression the ini file is changed when the camera is first connected…
Another remark: if I delete the .ini and start the software without camera, at the next start I get the framebuffer and the histos up again.
I hope this data might help to find what is going on on my machine… Thanks in advance for your help!

OpenMVIDE_ini_nextStart.txt (2.23 KB)
OpenMVIDE_ini_afterExit.txt (2.23 KB)
OpenMVIDE_ini_cameraConnected.txt (1.39 KB)
OpenMVIDE_ini_firstStart.txt (1.3 KB)

Thank you! This is super helpful!

Hi again,

It seems the problem has gone by deleting the whole ~/.config/OpenMV directory. Now, no such non-showing up problems seen and the drawer can also be reached.
I don’t know what happened during the first installation (the only thing was the camera firmware refresh, but I thin everyone does it), but now it works fine.
Thanks for your help and time to figure it out!


Probably old stuff in there. I’m almost … done with the IDE. Only a few more things to polish and I’ll be able to say it’s not beta anymore.

I have the same problem on Windows 8. Fresh install of the IDE. FIrst time using the camera. What files or folders do I delete and where are they?


There must be some init error with this code. I’ll put some logic in to make it smarter. When I tested on my machine and all he VMs I have it worked fine. Sorry about this.

Try this new IDE for Mac. I looked at the code and the only error I could find was that I applied size settings before the main window was shown which can causes issues. I’ve now moved settings to be applied after the main window is shown.

Your forum messages imply you don’t care about getting an answer/solution to your problem. “Well it seems to be missing is not something you would post if your looking to get your issues resolved.”

Hi kwagyeman… I’m interested in this answer though I’m using Windows 10, 64 bit machine, and I did another clean install of OpenMV IDE, and I’m still having similar problems.
I ruled out driver problems, as I was able to get images from the framebuffer when I tried running Tools>>Machine Vision>>Threshold Editor after running the Helloworld script, which gave me an image!

But I too cannot see the framebuffer and histos, much like what the original poster had in his screenshot (although my problem is on Windows instead)
I’ve tried dragging from the edge of the IDE to bring out the drawer, but all I could manage was to resize the IDE Window… :frowning:

I’m superexcited about the board, and can’t wait to get started playing with it! Any help would be very very much appreciated!