Failed to detect HM0360 VGA Monochrome DVP Camera

I have connected to R1GIGA (with Shield and HM0360 VGA Monochrome camera) and followed the guide to setup OpenMV IDE on my mac. When I try to run the display or HelloWorld example, I get an error “Failed to detect the image sensor or image sensor is detached”. The camera should be properly connected as I can run the Arduino specific examples to display camera feed on the shield. I can see Firmware is 4.5.5. Plus, I have also updated the setting to Grayscale and QVGA. See snippet from HelloWorld example. Any help is deeply appreciated.

import sensor
import time

sensor.reset() # Reset and initialize the sensor.
sensor.set_pixformat(sensor.GRAYSCALE) # Set pixel format to RGB565 (or GRAYSCALE)
sensor.set_framesize(sensor.QVGA) # Set frame size to QVGA (320x240)
sensor.skip_frames(time=2000) # Wait for settings take effect.
clock = time.clock() # Create a clock object to track the FPS.

while True:
clock.tick() # Update the FPS clock.
img = sensor.snapshot() # Take a picture and return the image.
print(clock.fps()) # Note: OpenMV Cam runs about half as fast when connected
# to the IDE. The FPS should increase once disconnected.

Ibrahim just merged in a feature to enable these cameras on the GIGA.

Do this, go to Tools->Install Latest Development Release.

Then it should work.

Thanks a lot. Sensor getting recognized now but getting a new error. “Runtime Error: Sensor Control Failed”. This occurs on the line sensor.reset() of the code I pasted above.

firmware.zip (1.1 MB)

Please try this firmware. I just enabled a fix that was required for the HM10B0 to work on the Portenta H7 on the Giga (which uses the same processor).

I don’t have the schematics, though, for the camera modules. Arducam didn’t post them on their product page. So, can’t say what’s wrong… We only support the OV7675 right now. However, there’s no reason we can’t support these other sensors.

Trying it out; but now post uploading this firmware, I get a confirmation message stating “DFU firmware update complete!” Please click OK post blue led blinking or the pop up for seeing the internal flash drive mount. I get neither the blue light and nor do I see the drive being mounted. I let it stay like that for ~5 minutes but no luck.

I clicked ok post that (i.e. without waiting for blue light or mounting), but it doesnt connect to the board at all.

I just loaded this one and it worked without any issues.

firmware.zip (1.1 MB)

Make sure to extract the zip file and load the firmware.bin using Tools->Run Bootloader.

Thanks. This one loaded up, but the same error persists “Runtime error: Sensor control failed”.

Ah, I don’t know what the error would be then. Given that it discovers the camera sensor, it must be due to a power rail glitch.

I don’t actually have any of these sensors on me. I’ll ask Arduino for both. However, it will be a while until this is debuged. Ibrahim may be able to fix it sooner.

Thanks a lot for the super quick replies and your efforts to resolve this. I truly appreciate it. I will wait for the fix and will learn other things in the meantime :grinning:. Much more to learn before I get to advanced image processing.

Your bug is tracked here: HIMAX Sensors not working with Arduino Giga · Issue #2226 · openmv/openmv (github.com)