Cant conect to custoum board on the OpenMV IDE 2.9.2 and 2.9.3 (latest atm)


I cannot connect to a custom openmv board on the last two releases (2.9.2 and 2.9.3) of the OpenMV IDE when the firmware is uploaded. The board is based on a OpenMV Cam H7 as far as I know. When I run the ‘Do you have an OpenMV Cam connected and is it bricked?’ window. It can connect again, but code crashes when I try to get an image from the sensor.

On the older releases of the OpenMV IDE (I have tested back to version 2.6.9), I can connect to the camera with the custom firmware on the board. I will use one of the older releases for now. I have no idea why it does not work on the last releases.

We did change things around in our debug protocol. The IDE uploads firmware way faster now. As for why it doesn’t work on a custom board with custom firmware I cannot say.

I can upload the firmware with the fast bootloader on version 2.9.7 and i am able to connect on version 2.9.0. So it is only the connecting part that does not work.

I have now rebuild the firmware from scrach based on the latest firmware in the github. This solved the problem. I was working on previously made firmware that is apperently not compatible with the latest IDE.