Cannot "import sensor" for the camera "OV5640-MOD R3"

I was trying to connect an “OpenMV-H7 R1 (10/27/18)” to a camera module “OV5640-MOD R3”, but not successful. it showed “RuntimeError: Failed to detect the image sensor or image sensor is detached.”

(Note below: I tried other camera modules, they are all working fine. e.g. OV5640 R1, MT9M114.)
What should I do to get it working?
Thanks very much.

That sensor is enabled in our latest firmware: openmv/src/omv/boards/OPENMV4/omv_boardconfig.h at master · openmv/openmv (

So… it should work if the hardware is fine.

I can verify the firmware works with the H7 base.

Dear kwagyeman, thanks very much for the quick reply.

I tried the “OV5640-AF R1”, which works fine.
It’s only the “OV5640-MOD R3” module, which is not connecting.
Is there a method to diagnose the sensor?
(or is it a discontinued product? no more maintenance.)

No, both should work. They have the same camera chip. They are both supported.

I can confirm that the ones I have function.

I guess clean the connector? Check for messed up pins?

Thanks for the confirmation.
I cleaned the connector by IPA 70%, still no improvement.
Not sure what else I can do to get some clue. (any PDF for the camera module schematics?)
Or I might just guess the camera module has been damaged during student usage.
Thanks very much for all the help.

Schematics are here:

openmv-boards/openmv4/sensors at master · openmv/openmv-boards (

We are in the process of converting our eagle designs into altium and generating 3d CAD for them along with online viewers on the product pages like we have for the RT1062.