Arduino Nicla Vision WiFi Firmware not found on OpenMV

I’ve got the WiFi working on the Nicla Vision using Arduino IDE by running the WiFiFirmwareUpdater, but when I switch to OpenMV to start coding with MicroPython, it prompts me to load and install the newest firmware. Doing so erases the one I downloaded via Arduino IDE and installs the latest firmware. However, when I run the WiFi examples, I get the following error:

Trying to connect. Note this may take a while…
[CYW43] could not find valid firmware
[CYW43] HT not ready

Is there a way to download WiFi firmware with OpenMV?

Our IDE installs the right firmware for the WiFi module and the firmware for the MCU at the same time whenever you program the board from OpenMV IDE either using the run bootloader option or clicking on the firmware version label and updating to latest.

When I click on the Firmware Version label a prompt appears that says “Your OpenMV Cam’s firmware is up to date”, the version installed now is 4.4.2, but sadly I am still getting the “could not find valid firmware” error when I run Any ideas to what is going wrong? Appreciate the help!


There is something wrong with the default example. Use this script instead:

# Connect Example
# This example shows how to connect your OpenMV Cam with a WiFi shield to the net.

import network, time

SSID='' # Network SSID
KEY=''  # Network key

# Init wlan module and connect to network
print("Trying to connect. Note this may take a while...")

wlan = network.WLAN(network.STA_IF)
wlan.connect(SSID, KEY)
while not wlan.isconnected():
    print("Trying to connect. Note this may take a while...")

# We should have a valid IP now via DHCP
print("WiFi Connected ", wlan.ifconfig())

I just tested it on my nicla with firmware version 4.3.3 which you can download from here:

See the firmware.bin file.

I just swapped out the Nicla Vision board with another, and the new one worked with the above firmware so it might have been a hardware issue then?

Could be. Not sure what was going wrong.