WiFi not working I think?

Can not seem to get Wifi working with 2.5.0 release. I ran the scan.py script and it just hung. Just sits there waiting for something. Then tried to connect to my network and kept saying its waiting to connect. Not sure if it me or the hardware.


Ibrahim, can you test this out?

Just tried it again and still not working.


If the cam just hangs when running scan.py it means the shields is not responding. You should double check the pins and make sure they’re making full contact.

Thanks. Must have blown the shield. Just ordered another one.

Ok. Got the new WiFi board and scan works fine, no issues. I can connect to the network no problem. But I am having problems with the Firefox browser. Keeps giving me unsecured network but when I do page info it does not allow me to change permissions. Tried Chrome, IE, and IE11.

Any suggestions.

Maybe an update broke things? I’ll have to check. I’m going to be doing a big push on getting wifi programming working soon so it will be more useful in about a month. Thanks for buying it.

Ibrahim, any thoughts?

DId just try on a Ubuntu virtual machine but no luck. I am running windows 10 64 bit version but I did have it up and running in Firefox a couple of months ago. Just as a fyi

Oh, I was talking about how FireFox works. If they updated the code for it to require https… then… yeah.

Hi K. Thought I would give you a little more additional information on the config. But anyway, got it working. I was using the default port of 8080. I changed it to 80 and firefox connected no problem.

Think the only issue is to improve the image quality and the be able to increase the image size when viewed in the browser. Can not wait for the wifi update.



I can connect to 8080 in station mode. I tested with Firefox 55.0.2 and Chromium 60.0.3112.101 (Developer Build) (64-bit)

I couldn’t in station mode. Once I changed to 80 I was able to connect. It must be something with my router settings. I have to check it eventually. Figured I would post if anyone else had a similar problem.

Thanks for your help.