Unable to import the ulab library (numpy)

Hi,
I am trying to import the ulab module to the OpenMV module but I’m getting an error, although I have installed the latest version of the OpenMV IDE.
I’m importing it as: from ulab import numpy as np

Thanks.
image

Which camera model are you using? It should be enabled for most cameras.

I’m using OpenMV RT1062

Hi, it looks like this was disabled in the release firmware. We have since fixed this.

Please do Tools->Install Latest Development Release.

Hi, thank you.
I think I have a problem with the connection of the camera to my computer, because I can’t update the firmware. When I click on “Install Latest Development Release” or when I click to the “Firmware Version” box, I’m getting the following message:
Capture

Please download this: https://github.com/openmv/openmv/releases/download/development/firmware_OPENMV_RT1060.zip

And install firmware.bin file by going to Tools->Run Bootloader and selecting the firmware.bin file after you unzip it.

If that fails to work something else is wrong. Are you using windows 10/11?

Hi, I tried but I-m getting the same message. I’m using windows 10.


Thank you,

Hi, can you reinstall the IDE? It seems like something is broken with it.

Also, you can try deleting your resources under:

/AppData/Roaming/OpenMV IDE

And just delete that folder. This will force the IDE to re setup its resources.

Hi, I tried deleting the resources and reinstalling the IDE, but it seems the problem is still there. I’ve checked the different tools provided by the IDE interface and I’m facing some problems:

  1. I can´t open the examples because it says that no examples have been found (see the picture attached).
  2. I can’t check the updates for the firmware when I click on the bar at the bottom of the screen:
  3. I can’t import the libraries because it seems the IDE can’t find them.

I hope these information to give more evidence about the problem.
Thank you so much in advance

All these issues seem to indicate that the IDE has no access to its resources on your PC.

I haven’t seen this error before.

Can you email us at openmv@openmv.io. I can provide direct help support via a video call. It’s probably something simple to fix and this will go faster if I hop on a call with you.

The issue was resolved by deleting the IDE resources under /AppData/Romain/OpenMVIDE and restarting.