Error in Ubuntu

I have IDE running ( I think!) under Ubuntu in VirtualBox on my MAC.
I have enabled the USB connection in VirtualBox.
When I try to ‘connect’ the IDE (it opens and shows “helloworld.py[disconnected]”, i get the message box shown in attached screen capture.
in addition, it is complaining about a missing file/directory: where do I get this file from ?

thanks in advance
openMV_error.tiff (52 KB)

It’s included in all release packages, please see the following:

Note this message is displayed on other platforms (OSx/Windows), on Linux it shows a hint about installing udev rules. Which version of Ubuntu you’re using ?

Thanks for quick response:
I am running Ubuntu version 14.04

I downloaded the latest release from the link you gave, but nowhere in there is there a file/directory called “openmvcam”…

I’ve attached file listing after I unzip the release.

I’m not a Linux guru so perhaps there is something I need to do to generate this file?
openmv_error2.tiff (121 KB)

See the following:

The /dev/openmvcam is a device. Its basically like on windows COM5 etc. missing.

You’re getting that error because the udev rules aren’t installed. Please follow the getting started guide to get that working. You just have two execute a two simple terminal commands to install the udev rules and once that is done the camera will show up.

I did execute the two commands re the "rules’; I am going to try an updated Ubuntu on VMware rather than VirtualBox

(1): I installed Ubuntu on a virtual machine in VMware. I executed the 2 commands to update the rules, plugged in the camera [ more on that at tend] and tried to open the IDE and got the attached error messages.

(2:) The camera LED’s in VM were either solid red or no LED"s at all.
When I plug in camera using Ubuntu on VirtualBox, I get solid red with flashing blue.

…when will you have IDE that runs directly on Mac? :slight_smile:
openMVerror3.tiff (356 KB)

I’m working on the Mac port right now. Hopefully we’ll have it working before the end of the week.

The LEDs aren’t an issue. As for the error that’s because your system libraries are too old. Ubuntu ships with old libraries for some reason. You’ll have to update them. Please try updating Ubuntu or “sudo apt-get upgrade”

Sorry about this being a pain right now. It’s really hard to get stuff working easily for Linux. The windows port works better…

Ok, thanks.
I have standby Windows tablet running windows10, I will try to get it running on it.

Cheers,

Still trying to beat this dead horse:

  1. I ran “sudo apt-get upgrade”
  2. tried to run openMV ide
  3. got a new set of error messages, see attached.

I am sure this is problem with Ubuntu, but I’m at a loss as to what to do next. Any hints?
openmv_OS_upgrade.tiff (349 KB)

I don’t know how to fix this error. Google doesn’t seem t have any info on what needs to be done.

Um, so, it would probably be easier to get the IDE running from source on Ubuntu than the compiled image…

See this: https://github.com/openmv/openmv/wiki/Firmware-Development

You can skip the whole qt-creator part. You just need to execute the install commands and linux. Then download the repo we have online. Once you do that just follow the instructions under “OpenMV Development” for command line operation.

It’s not actually that much of a pain to use…

Sorry about this. If Ibrahim has any suggestions he’ll let you know.

question:
When I check version of Python that ubuntu is using, it shows version 2.7.11+; there are python 3.5 files when I search for ‘python’ files, but obviously Ubuntu is not running that version.
Which version of Python should be used for IDE?

Python 2.7

Hi, I just tested the IDE on Ubuntu 14.04 and it works, I noticed you’re still using v1.4 could you try v1.5 ?

Also, you probably know this but anyway, after you connect the camera (physically) you need to connect the serial port to the VM:

Note: I don’t recommend using OpenMV with VM, the serial becomes really slow on VM, but it should work.

Update on my efforts:

  1. linux/ubuntu:
  • i get same GLIB errors with version 1.5 as I did with 1.4
  • camera is detected, shows up on GUI and I can see the files on the device [ is called 'Interbiometrics openmv virtual comm port in FS mode]
  • I am giving this up for time being
  1. windows 10 on Surface:
  • version 1.4 IDE opens
  • please confirm what combination of “preferences” i should be using; options i get are board: openMV1, openMV2; baud rate: 921600 and 12000000
  • based on the error message, I assume I should be using openMV2
  • I’ve tried all combo’s and get python error as follows when I “connect”:
    File “main.py”, line 7 in module
    exception IDE Interrupt
    Micro Python v1.4.4 g4f6880b on 2016-05-03; openmv2 with STM32f427
  1. windows 10 on surface: if i try to open version 1.5, i just get spinning cursor and it doesn’t open. Initially Windows blocked it from opening saying I was at risk!
  2. Please note that the links on your web site are to version 1.4 not 1.5 for both windows and linux…

Any suggestions??

This is Not an error, it means the camera is connected. As for the preferences, you should use OpenMV2 and 921600 baud rate on Windows (restart the IDE after setting the preferences.)

The IDE uses PyInstaller which is flagged as malware by some anti-viruses, you should tell the antivirus that it’s safe to run.

Thanks, I got it working on my Windows Surface, finally!~

I’ve given up on the Ubuntu version; I tried the suggestion of installing using the instruction on the firmware installation page; the ‘numpy’ wasn’t found so I gave up.

I will wait patiently for the Mac OS version of the IDE.

Cheers,

I have a Mac so I spent some time last night trying to get that working on my Mac. Wasn’t able to do so :frowning:. Ibrahim will have to get it working an he doesn’t have a Mac right now.

After I get the tutorial online the IDE is pretty much the biggest fire right now for us so I’m going to spend considerable effort fast tracking the new Qt based IDE which already has the cross platform installation framework done for us. It’s not going to be ready probably until September.