Unable to connect to your OpenMV cams normal bootloader


I’m trying to upload some firmware changes on the H7. I have done this several times before and it has worked fine. The only difference now is im trying to do it on a virtual machine, specifically on Ubuntu 14.04 (Guest OS) with the host OS being Windows 10. When I go to run the bootloader and the device is connected, the device disconnects and I get the prompt to hit cancel if it takes more than 5 seconds which gives me the error contained in the title of this post. Do I need to reset the cam to default? If so how do I go about it.

When I click run bootloader and point it to the new firmware file a green light flashes 3 times followed by a white light which is when it disconnects.


This does not work well on a virtual machine because the IDE resets the camera to run the bootloader, at which point it gets disconnected from the VM… I think with virtual box there was a way to assign the device to the VM, you should try that if it’s possible.

Just to let you know I got this working using the shared folders approach as per your documentation. The one thing I did notice is when I run the boot loader to update the firmware the Cam has to be disconnected from the ide before I try do it which I never noticed before.