RuntimeError: Failed to detect the image sensor or image sensor is detached on Nicla Vision board

Hi, I attached my Nicla Vision board to my pc and when I run a script in OpenMV, I get an error.

RuntimeError: Failed to detect the image sensor or image sensor is detached

I have been able to run most of the examples a few weeks ago. I am now back working with the Nicla Vision board, however, I now have this issue.

Any thoughts on how I might fix this?

I am able to connect to the Nicla Vision board using OpenMV.
I can see the files on the Nicla board in the file manager.

Thank you,

Please check that the image sensor is attached correctly?


I am having the same error, I am pretty new on this field, did you find a solution, or can you point me to a few items to be checked of why this is happening?

Thank You

Can you check that the image sensor is attached and the connector is pressed in?

From what I can see the connector is attached and the GC2145 is present (see pictures) but the OpenMV does not recognize it. Thanks for answering

@iabdalkader - Maybe our driver needs to be more robust to fix this issue? Any thoughts?

The driver/firmware is working fine, we’re using it all the time. This might be a hardware issue, the ribbon cable might damaged from the soldering, or the sensor is not attached correctly. Not much we can do, you should try it with Arduino firmware let us know if it works.

You should also try the latest stable release 4.3.3 here

We’ll push that update to the IDE soon.

Thanks for following back on this issue, I tried the v4.3.3 and all the sensors are functioning well except for the GC2145 which is still not being recognized when running.
Do I to install any additional drivers for the GC2145? I am working on Windows 11 Pro.
I run the Arduino example of CameraCaptureRawBytes

After, I try to read with Processing no errors but not video.

There’s a variable in the processing sketch, usegrayscale or something like that, should be set to false. If it’s still not working, then it’s very likely a hardware issue.

Yes “useGrayScale”, I set it to false, but it still doesn’t work. Thank you so much for the help :slight_smile: