Problems with H7 on a Mac

Hi, I have just purchased the H7, followed the install instructions, but do not get the board mounted as a drive on my Mac.
I get the green flashing light, then blue.
Mac is running 10.14.4
OpenMV IDE is 2.2.0

Newbie to the H7 so struggling a little :frowning:

I have tried reloading DFU and get the following error message

Traceback (most recent call last):
File “/Applications/OpenMV”, line 20, in
import usb.core
ImportError: No module named usb.core

I have checked an libusb and pyusb are installed

(base) Stephens-MBP:~ stephen$ pip list | grep usb
libusb 1.0.22b4
pyusb 1.0.2

Mmm, when you mention that the board doesn’t mount on Mac do you mean that you don’t see the flash drive appear and you can’t connect via OpenMV IDE? If so, please check that you are using a USB cable with power + data. The flash drive always appears for every os. That is very stable code.

I haven’t had any trouble with my M7 or H7 on my Mac. Just to confirm, I plugged it in a second ago, and sure enough, the drive popped up on my desktop, mounted and ready to go. I can also interact with it through the IDE. Lastly, I can see it listed under /dev and I can initiate a REPL session via ‘screen’. So, I suppose that doesn’t help you very much. Sorry. I’m currently running OS 10.14.2, but I recall the M7 working great for me at the beginning of the year, when I must have been running something older, not even 10.14 I suspect. I can’t remember how to see the H7’s firmware version so I can’t tell you that right now.

Hmmm, my first question is, aside from the drive appearing on the desktop – or failing to – do you see the device appear under /dev? Unplug it, then “ls /dev/usb”. You shouldn’t see anything (well, not the H7 at any rate, I don’t know if you have other devices attached). Then plug it in and enter that command again. Even if you saw some other devices the first time, you should see more devices this time, one cu and one tty. So, run that experiment. Do you see the device show up under /dev?

Another question is what you see under /Volumes. Same as above. You can “ls /Volumes” while it is not plugged in and after plugging it in, and even without know what’s it’s called you should still see some new device appear in that list after plugging it in. However, I strongly suspect you actually won’t see anything appear under /Volumes, because if you did, then surely it should have showed up on the Finder desktop as well.

One last thing. While in the Finder (not some other app, make sure Finder appears in the upper left of your screen), get preferences either via Command-comma or from the Finder menu (not System Preferences under the Apple menu). The Finder preferences will have a checkbox labeled “External disks”. Make sure that box is checked or you really won’t see devices like the H7 appear on the desktop even if they are listed under /Volumes and otherwise available. You should always be able to see all mounted disks in the sidebar of any Finder file-browsing window, regardless of the desktop. Again, that sidebar should always match the listing under /Volumes…to the best of my understanding.

OK, Thanks, I bought a new cable when I bought the H7 module.
I will try another cable.
Thanks for your feedback and support.


Result, duff cable, thanks so much for that, working on windows now - next stop Mac :slight_smile:

Slight update - issue traced to the H7 housing - I bought the H7 and enclosure - the enclosure was allowing the microUSB cable to push in deep enough to get power, but not data. Removed the camera from the housing and tried the original cable again - all working.

Weird, we checked the case against about 25 different microusb brands.

Thanks for your sharing!. If you want to find quality products for PC, check out my web page Overclockers UK