Problems cloning the repository from github


I’m having problems cloning the OpenMV repository. I keep getting the following error messages:

Cloning into ‘openmv’…
remote: Enumerating objects: 325, done.
remote: Counting objects: 100% (325/325), done.
remote: Compressing objects: 100% (237/237), done.
error: RPC failed; curl 56 GnuTLS recv error (-9): A TLS packet with unexpected length was received.
error: 674 bytes of body are still expected
fatal: the remote end hung up unexpectedly
fatal: early EOF
fatal: index-pack failed

At first I thought it must be my network or git installlation. I have tried switching to my wired network but still the same problems. I have tried cloning the Micropython repository and there is no problem at all with that it cloned fine with that and also the AprilRobotics apriltag repository and those both cloned fine.

I am wondering if there is so problem with there is a problem with a file in the OpenMV repository that is causing the clone to fail ?


How do you clone where’s the git clone command ? Also this may be related: ubuntu - How to fix git error: RPC failed; curl 56 GnuTLS - Stack Overflow

I followed the instructions on

It has worked for me for the past couple of years without issue just suddenly stopped and I wondered if anyone else has had similar. I already tried a few fixes and nothing works.

Please note I’m doing a straight clone not trying to pull.


No not really no one else has reported an issue with cloning the repo, plus CI builds are working fine.

Thanks for confirming all OK at your end.

It turned out to be the parental controls on our internet provider (We are with Virgin Media in the UK.) Turned those off and all working :slight_smile: