Problem: Broadcast Discovery Port


I recently got and openmv cam, I have been using it in both my laptop and in a desktop PC at work. 2 days ago I got the error about the Broadcast Discovery Port, I can’t use the camera on the PC. I can use it on the laptop with no problem. I had rebooted the computer, closed all applications, looked in the forums and I have no clue why I can’t use it in this PC.

Do you any ideas on how I could work it around?


Hi, that issue is related to Wifi programming support which isn’t rolled out yet. You should be able to ignore it.

Um, does the IDE have permissions to access ports on your PC? The broadcast issue is unrelated to USB working.

That is the thing! I was able to use it a few times the first days when I go it…then I didnt use it for a few das (a week maybe), so the last few days I have tried to use it again I am receiving the error I am mentioning.

This is a desktop PC with no Wifi Card/option. I ignored the problem but the camera it is not recognized.

Once plugged the USB drive it is not detected. I can use it on my laptop with no problem.

I could keep using it on my laptop, but from time to time I would like to be able to test some stuff on the dektop. If you have any pointers that would be great.

thanks for your time,

How can I know if the IDe has permission to access the ports ? I know It did at first because it was working

Mmm, okay, can you verify that the OpenMV Cam’s USB flash drive still appears along with it’s VCP serial port? They should appear in windows device manager. If they don’t appear then we likely need to reset the firmware.

I have the same issue. The IDE froze so I had to kill the IDE program from the task manager. But there is still an OPENMV process active on the system that is hogging the port. When I try to kill this process it tells me access denied. It does not recognize the camera until this process has somehow been killed. I have literally lost >30 hours of time with this problem. It is hugely annoying!

Nothing kills these processes. Not even a reboot helps. So the effect of this is that you can never use that usb port again. It hogs the usb port making it unusable. I have two processes hogging 2 ports now. I am running out of USB ports fast.

taskkill /f /t does not work.

Please try to resolve this as we have no more time to find out why this process cannot be killed. We have even rebooted about 20 times. After reboot the process is still hogging the USB port.

@KevinFreese Do you also get the warning message about the discovery port ? I’m just guessing but it’s possible that when the port is reserved or can’t be used by the IDE, it gets stuck trying to open that port. Anyway, we’ll work on getting this bug fixed very soon.

Hi, the wifi discover port has nothing to do with the VCP port the IDE uses to communicate to the camera. For the wifi discovery all I try to do is to bind to a particular UDP port and I display that message if the bind fails.

As for the VCP port issue. It’s true that it’s possible to have an unkillable process in windows. This happens because a thread calls a kernel level method and then that kernel method never returns making the thread get stuck in execution and unable to respond to kill signals from the OS. However, there’s no code I can write to fix this as I would have to edit the kernel driver where the issue is.

A reboot must solve this issue however. The IDE had to start the thread for it to come back. So, I can only assume you mean that you see the issue happening when you start the IDE again and you get a stuck thread.

If this is happening to you repeatedly it means your PC/USB cable may be problematic generating a condition where the kernel driver crashes and gets stuck. As the driver is closed source I can’t really say what is wrong. However, I have tried to debug this issue before and I literally found that I would make a library call with my code and that call just flat out never returns even if I removed the camera from the system.

Can you describe the exact steps in detail you do to cause this issue? Also, have you tried using a different USB cable. I definitely found the kernel driver more likely to crash if the USB cable was very long.

No. Unfortunately even when I reboot and I completely remove the electricity of the machine, the process remains there. it is somehow respawned at bootup.

Even WITHOUT starting up the IDE and WITHOUT having any camera attached to the computer, the processes remain. We can never use that USB port again.

I see other people have has a problem with the USB port not picking up the device. This is because that USB port has been bound to one of these orphaned processes. I will try to attach some images.


here is a image of the task manager. These openmvide.exe processes have been there for many days, regardless of rebooting the machine many times and removing electricity to the machine. I guess it is a feature of windows to bring back anything to life that was there previously.

Here are the other screenshots.

I tried everything to kill these processes. What eventually worked was to uninstall the IDE. Then Reboot. Then reinstall. Now the processes do not respawn and I can use the USB ports again. Clearly there is a problem with the IDE or related.


This is so weird. I have no code in the IDE to cause this to happen.

Mmm, okay, try this… Please startup windows in safe mode. Then move the IDE code folder (under x86 programs) to your desktop. Then reboot back into normal mode. Windows should not be able to spawn these zombie processes again. Then move the IDE back and it should work.

If windows keeps spawning zombie processes even without our binaries to run on startup something much more weird is happening on your PC.

I don’t know what I can do to solve this however. We don’t have any auto starting code in the IDE. It’s not us creating those processes in startup.

As for the serial thread in the IDE crashing and causing this problem initially… There’s little I can do there either since the bug is in kernel code. Our license does not allow us to distribute kernel software, just inf files which specific how to link together already signed kernel drivers.

Okay, it looks like you solved the issue.

I would say it’s more likely your computer settings than our fault however. We don’t have any auto starting code in our IDE. I know Mac has this feature to auto start software but it’s not available on Windows by default.