OpenMV H7 Cam does not stream video via RTSP

I am using from example in the OpenMV IDE. I try to stream vedio with vlc, but i don’t get any vedio streaming.

play_callback(pathname, session):
print(“Playing "%s" in session %d” % (pathname, session))

in the openmv ide terminal, I only see play_callback output.

Hi, it only works with the JPEG mode of the OV5640 for VLC. It doesn’t like the JPEG image format produced by our JPEG compressor.

If you use FFMPEG it works fine with our jpeg compressor.

Hi Kwagyeman,

As you suggested above, tried to use FFMPEG on windows 11 PC. By following the below url:

When we tried to stream it using command [ffplay.exe ] in CMD, we still couldn’t get any stream. Please refer the below output.

Any help on this would be much appreciated thanks!!

Did the camera report that it was streaming?

Hi Kwagyeman,

Yes, from RTSP code from openMV examples, the below pasted imag_callback function is being called only once.

Can you make a github bug on this on the openmv repo? I’ll debug it.

Hi Kwagyeman,

I see you have updated the RTSP code on 17th Oct does it resolve this issue? Can I try to use the update code.

Sorry, I haven’t had the time yet.

Hello Kwagyeman,

I have created a bug on this issue, request your help in this.