OpenMV Cam H7 Plus DFU Issue

Hi all,

If you have an OpenMV Cam H7 Plus please do not use the DFU bootloader with it. ST reved their hardware bootloader firmware vesion breaking DFU support for all their old tools. I.e. our windows DFU tool no-longer works.

With the help of Arduino however for support of their H7 Portena board we have integrated dfu-util-v0.9 for every operating system into the IDE and made all the command line windows pop-up and show status. DFU-util supports flashing the OpenMV Cam H7 Plus bootloader. However, no DFU software is currently able to flash the entire firmware image to Rev V silicon of the STM32H743 chips. Note, this issue does not affect the regular OpenMV Cam H7.

Anyway, first, all OpenMV Cam H7’s ship with a bootloader that should work fine. You never need to use DFU mode if that bootloader works. If that bootloader doesn’t work you will need the latest (unreleased IDE) to flash the bootloader sector of the OpenMV Cam H7 which will make it operational for firmware updates. After-which, the IDE can use our normal bootloader process to update your firmware.

I don’t have a work around for this issue that’s GUI based until the latest IDE is released. If I see enough folks are hitting this issue I’ll just push it out early without completing new features we were adding too it.

I believe I ran into this issue. I just received the H7 Plus and the power went out while it was performing the initial firmware upgrade. I was able to get it to enter DFU mode by jumping boot and reset, and waited for over an hour before finding this post warning me not to do so.

Do you know when the new IDE will be released? Is there a beta somewhere I can try?

What operating system are you using?

Windows 10, but I can use Ubuntu 16 or 18 if you have a script. I’m am embedded systems engineer so don’t be afraid to get technical :smiley:

I’ll give you a link for a windows binary download.

http://upload.openmv.io/openmv-ide-windows-2.4.1/openmv-ide-windows-2.4.1.exe

You’re going to want to use the Tools->Run bootloader option to load the <ide_install_dir>/share/qtcreator/firmware/OPENVM4P/bootloader.dfu followed by the <ide_install_dir>/share/qtcreator/firmware/OPENVM4P/firmware.bin.

Thank you! Worked great!