OpenMV 4.0.10 will not install on Windows 10

Steps taken:

  1. Start with OpenMV 4.0.1 installed and working
  2. Download and run installer for OpenMV 4.0.10
  3. Installer uninstalls 4.0.1
  4. Installer attempts to install 4.0.10
  5. This error message displayed:
  6. Click Cancel
  7. Run installer for 4.0.10 again
  8. Steps 4-5 repeat
  9. Run installer for 4.0.1
  10. OpenMV 4.0.1 installs and runs successfully
  11. Steps 1-5 repeat
  12. Steps 9-10 repeat

So, 4.0.1 seems to work fine whereas 4.0.10 cannot install.

Same here.
When selecting “Ignore”, the installation runs through without any further errors (at least for me).
Though, no idea what exactly I’m ignoring with this :slightly_smiling_face:

Huh, okay, will look into this.

It’s not an issue for most things as that’s just the certs for Arduino Boards. If you install the Arduino IDE it installs that.

Can you help me debug this issue? I’ll post the command I need you to run so I can get the error code in a bit. You can manually run the installer that it tried to execute and I should be able to figure out what’s wrong.

Can you manually run:


In the terminal and let me know what the output and error code are?

Path seems to be a different one:

cmd /k "C:\Program Files\OpenMV IDE\share\qtcreator\drivers\arduino\arduino.cmd"

I have to use cmd /k otherwise the console window just closes.
If I run the above in a console, Windows asks me for permission to run the “Driver Package Installer”. Once I approve this, it just returns to the prompt.

The whole thing:

C:\WINDOWS\system32>cmd /k "C:\Program Files\OpenMV IDE\share\qtcreator\drivers\arduino\arduino.cmd"

C:\WINDOWS\system32>echo %ERRORLEVEL%


Hope this helps.


Thanks, yeah, I just got the error too… must have broken this code somehow. It will be fixed.