IDE Serial Terminal stopped accepting keystrokes

When I first installed the OpenMV IDE under Windows 10, the serial terminal in the IDE worked fine. I hasn’t been accepting keystrokes for a while. It will still show output/errors and a REPL prompt I can’t use. I can send keystrokes through a Tools/OpenTerminal terminal (after disconnecting the IDE).

I have uninstalled and reinstalled the IDE and drivers, rebooted, and renamed my %APPDATA%\OpenMV\OpenMVIDE.ini file to force it to reconfigure from scratch. Still can’t use the IDE’s primary serial terminal. Also tried running as administrator.

IDE is version 2.6.9 connecting to an H7+ with the latest 4.0.1 firmware. Windows is now version 21H1 but the problem began prior to that 21H1 feature update. Device manager says the port is an OpenMV Cam USB COM Port (COM14) and the driver Provider is OpenMC, LLC date 9/9/2016, version (Also shows up as a MicroPy publoard Flash USB Device using Microsoft’s driver.)

Possibly similar to Is the serial terminal in IDE output only? but that was a while ago and doesn’t seem quite the same.

The IDE’s terminal just displays text from the camera it has never accepted key strokes.

There’s another feature called OpenTerminal under tools which opens a REPL terminal (for REPL mode) which accepts keystrokes. You probably used this. That’s more like an actual terminal. The main terminal in the main window of the IDE is output only. That said, when using this version of connecting to the camera you don’t get the full debug functionality. This feature was added to support any MicroPython board.

There’s a todo to add keystroke input support on the github action item list of things to implement.

Huh. I must give my imagination bonus points this past month for believing I had done this directly in the main IDE window. Guess that’s the sort of thing your brain does when having to pause a couple of weeks on a project! This is in fact exactly like the other post I referenced which I guess I didn’t quite understand. Thank you for your reply.