Connect OpenMV H7 to BeagleBone Black

Hello, Can i connet openMV H7 to beaglebone black hardware ?

Yes you could connect with serial (UART) or USB if the BeagleBone has USB host/OTG.

The BeagleBone has system: debian 7.8 , its compatible with openMV H7 ?
Yes BeagleBone has USB host , I can connect Web Cams, - dev (video0) , but when I connect OpenMV cam, I am not see (video0) device, so maybe, its not compatible

The OpenMV Cam appears as a UART vcp port. Please remember it’s not a webcam. You should see it under /dev/ACM0 or something like that. If you install our udev rules it will appear as /dev/openmvcam.

I find it - but the name is - serial, I try it to connect

serial - not work
But i found "ttyACM0"

do you think, that I should connect OpenMV cam to Serial Debug Port on BeagleBone black with FT232 USB to TTL Serial Converter Adapter Module ?

because there is Error: Cannot query ‘/dev/ttyACM0’: System returned (25): Inappropriate ioctl for device.

Hi, do this to identify the right port:

Unplug the camera.

ls /dev/*

Plug in the camera.

ls /dev/*

Whatever new dev device appeared in the camera. As for opening the port… It’s not a video device. You can open the port with a serial program like minicom.

only “serial” and “ttyACM0” are new

if its not a video device, So i cant connect it to Simulink Beaglebone yes ?

Imgur

It’s the ttyACM0 device. Um, I guess you can connect to simulink. OpenMV IDE should run on the beagle bone too.

Error code:
A run-time error is encountered when running External mode simulation on hardware. This usually occurs when a hardware resource, such as a web camera or an audio card, is not available or configured incorrectly. The log file, beaglebone_inversion.log, storing model diagnostic information on the hardware has the following content: Error: Cannot query ‘/dev/ttyACM0’: System returned (25): Inappropriate ioctl for device.

do you think that i should try FTDI USB to Serial adapter ?

Imgur

You can if you like. But, it’s not needed… What program are you trying to open the serial port with?

BeagleBone has serial debug header, I have thought that with this connection The ttyACM0 in Matlab would be worked…

I am using only Matlab and beaglebone,
or SSH connection with Putty- to find out Beaglebone data (dev. names, etc…)

So the Serial Port is needed to open by any program ??

I have no idea how Matlab opens the serial port. I can’t really provide any help in this case.

Um, so, yeah, just attach an ftdi cable to the cameras rx and tx UART pins and put a script on the camera that outputs data to the UART.

I tried to connect to serial from putty, with command ( sudo screen /dev/ttyUSB0 115200. ), I see only a frames of camera.
So should i try to connect RX TX pins of the Openmv Camera to ftdi cable and connect it to USB port of the BeagleBone ? (B image in attachment)

or you think, that I should connect to the Beaglebone “FTDI USB to Serial adapter” , and from adapter connect RX and TX to the OpenMV camera ? (A image in attachment)
and program openMV like this ?

# Image capture and sending via UART to BeagleBone

import sensor, image, time
from pyb import UART

sensor.reset()
sensor.set_pixformat(sensor.GRAYSCALE)
sensor.set_framesize(sensor.QVGA)
sensor.skip_frames(time = 2000)
uart = UART(1, 19200)

clock = time.clock()

while(True):
    img = sensor.snapshot()
    
    uart.write(img)
    print(clock.fps())
    time.sleep(10)

In this picture you can see connection, what connection do you think to try ?
Imgur

It would be option B. Also, please make sure to specify the the timout_char parameter when making the UART object as you will drop bytes otherwise if the value is too small.

Ok, I will try it,
If I use only the Rx and Tx pins from FTDI cable, should i use only normal USB ? , Or FTDI is required ?

https://imgur.com/undefined

I don’t know what you are trying to do.

I will try B

nex question:
FTDI cable is required ?
or can be used basic USB with 4 pin (2 pins are Rx Tx)

You need an ftdi cable to turn UART 5v signals to USB.

Ok, thank you for your time. I will try it :slight_smile: :smiley: