Charging - LED never turns green

Bought a LiPo battery for my board. When I plug the USB cable in, the blue “Charging” indicator illuminates, but it never changes to green. I left it for a full 12 hours and there was no change.

I can disconnect the USB-C and the board will run on the battery, so I know it’s getting at least some charge.

If it makes a difference, the markings on the cell are:

  • KC 805050 3.7V
  • 2500mAh 1910

where is this light located?
i know that openmv cams have micro usb and not typec.
do you have some new board with charging lights and usb type c connector?
What board do you mean?
Sorry i cannot understand you. some more info or pics maybe help.

Hi. It’s the Purethermal OpenMV, from GroupGets. Link to GroupGets page

image

It has a status LED (indicated by the red arrow) that is blue when charging, green when fully charged and red when the battery is low.

Mine never turns green (haven’t tried running the battery down to see if the LED will turn red)

Ok isee.
Did you try with a different cable;
Did you try with different power supply;

Yes - tried two different cables & two different chargers. No difference.

Dear friend some times both chargers or cables may be faulty.
Do you have the ability to measure voltage and current during charge;
Some USB tester like these:
https://www.google.gr/search?q=usb+tester&tbm=isch&ved=2ahUKEwjf0NK2qtf1AhXE7rsIHX3dA1cQ2-cCegQIABAB&oq=usb+tester&gs_lcp=ChJtb2JpbGUtZ3dzLXdpei1pbWcQARgAMgQIABATMgQIABATMgQIABATMgQIABATMgQIABATOgIIKToECAAQAzoICAAQgAQQsQM6CwgAEIAEELEDEIMBOgQIABBDOgUIABCABFDvFVjjRmChU2gAcAB4AoAB9wGIAf0pkgEGMC4zOS4ymAEAoAEBsAEFwAEB&sclient=mobile-gws-wiz-img&ei=omT1Yd_3LsTd7_UP_bqPuAU&bih=554&biw=360&client=ms-opera-mobile&prmd=isvxn&hl=el
Is your battery new;

Good morning. I do have a USB meter - just tried hooking it up, using two separate chargers and two different cables. The meter doesn’t have any USB-C, so that limited my options of cables to USB A->C.

There were minor differences between the two. One charger seemed to settle at 4.7V where the other ran steadily at 4.8. When battery charging only (screen off), the first charger only put out 300mA, where the second would show 480mA steady with occasional “blips” up to 620.

I’m going to leave it connected to the second charger (which I hadn’t tried before) and see if that will change the indications of the charging LED.

This is a brand-new battery purchased from a (IMO) reputable local store.

Same issue here, charge LED stays blue, does not turn green, but the power consumption goes down.

4.7 - 4.8 are low voltages for USB type c connections. Please use a proper good enough power supply. I don’t know if it is a bug but your chargers aren’t good enough…