SD card failing to be detected on the RT1062

Can’t tell if this is a “me” issue or the board issues. For whatever reason when a 1GB SD card is inserted into the slot, nothing happens. Plugging the board into the computer instead of the memory of the SD card, (as I think the docs say it should). Multiple SD cards tried with FAT and FAT32. The SD cards themselves work fine when connected to a computer. I have tried putting the .openmv_disk file on there without luck. I have tried mounting the SD card like:

def sdcard_init():
    os.mount(machine.SDCard(), '/sd')
    if 'sd' in os.listdir('/'):
            print("SD card mounted successfully!")

        print("Failed to mount SD card.")
    # Let new settings take affect.
    if not "images" in os.listdir():
        os.mkdir("images")  # Make a temp directory

but that just gives the error: OSError: [Errno 19] ENODEV
which seemingly means that no SD card is detected.

I’ve updated the firmware and the IDE itself just to be safe but :frowning:

I really hope it’s not a board and just me, but I’d like to hear your guy’s advice.

I think I got it working! It seems to be the brand of SD card that I used. Got a different kind and it just worked! :man_shrugging:

1 Like

Our driver rarely has issues for these things. However, it is generally extremely hard to support all sd cards ever made.

Given you mentioned it’s 1GB that must be an old card. Stuff before SDHC didn’t follow the spec that tightly.