OpenMV PureThermal software files

Hi all,

I am trying to get my OpenMV PureThermal Lepton module working. The board connects and displays the OV5640 cam output just fine, but when I choose a Lepton example from within the OpenMV IDE I get runtime error: sensor control failed. This happens with any of the lepton examples. Am I using the correct files for this board? I would like to get the touchscreen working but no output to it as yet either.
My lepton 3.5 module works just fine in a Pure Thermal 2 card and I have tried seating and re-seating the sensor numerous times.
Any hints appreciated.

What do you see in the IDE down in the output text box it should tell which firmware the camera is running if you start/stop a script.

Hi Andy,

I run into the same problem with all examples using sensor.IOCTL_LEPTON_xx.
Try the examples using the fir library (located in “Examples > OpenMV Boards > Thermophile Shield”).
Those are working with my OpenMV Pure Thermal Board without problems.

Best regards,

Thank you guys, turns out it was an eyelash in the flir socket preventing the sensor module seating properly.