How to install openmv-ide to raspberry pi for raspbian OS

How to install openmv-ide to raspberry pi 3 for raspbian OS ,Thanks!

Qt doesn’t provide native binaries for the PI. You’d have to compile their whole library of code and then the IDE on the PI. This would like take on the order of 3-4 days of PI compile time.

If there’s enough demand for this I’ll put the work in. But, so far you’ve been the only person asking. Anyway, that said, OpenMV IDE actually kinda needs a fast CPU. Not sure how well it will perform on the PI. We draw images and do graphs and whatnot.

Sparkfun electronics has a download of openmvide for the rasberryPi however I have not been able to get it to launch. Suspect that it is missing some libraries but my Linux is too thin for me to be sure. Any suggestions?

You’re linux is most likely too thin.

Did you run the script that comes with the IDE? It should install anything you need.

If the IDE still doesn’t run please post the error messages you’re getting.

Thank you for your response. I have succesfully gotten the IDE to run on my PI using the script. However it will not connect with the camera. Tells me that no camera is detected. tried to install pyusb and was told it was already installed and upto date. OK so I installed the ide on my windows 10 machine and have the same problem. any suggestions?

Hi, please verify that the USB cable you’re connecting to the computer provides power and data. There are a lot of power only microusb cables folks have.

I have solved my problem. The plastic case on the openMV Camera does not alow the usb cable to fully engage. the camera got power but not signal. I took the camera out of the case and I was able to insert the cable an additional 1/16 of an inch and now everything works. Filed the usb cale hole larger in two cameras I purchased and they are now working inside the case. Mechanical problem! Thank you for your assistance, now I have to brush up on my LINUX and Python. - Joe C.

I’d like to follow up on this, as I’ve installed OpenMV onto my Rasberry Pi 3 but when I run the file… nothing happens, no error or anything and nothing comes up…

This is after I’ve ran the file…

any thoughts?

Please execute the file from a terminal window. Um, there’s a post where someone solved the issue recently around on the forum. You may have to install some additional things.