Firmware 4.0.2 build - no module named 'time' error

Hi,

I’m new to OpenMV and I have an OpenMV-H7-Plus R3 board.
I followed the ‘Firmware Guide’ (openmv/README.md at master · openmv/openmv · GitHub) and successfully completed all the steps to build the firmware. Using the OpenMV IDE I downloaded the firmware (firmware.bin file in /src/build/bin/).
After reconnecting the board, the white LED flashes fast, and in the internal flash ERROR.LOG file created with the message:

"FATAL ERROR:
no module named ‘time’ "

Firmware build is essential, since i will need to change src files and rebuild the 4.0.2 firmware.

Can you please help me?

Thanks,
Dani

Please load our pre-built firmware. If you are building firmware yourself we cannot know what the issue is if there was a problem in your build. Verify the board is fine. Then, if that’s the case… the issue is likely that MicroPython is not setup well. Make sure you cloned the repo right and that you updated all submodules.

The board works fine with the pre-built firmware.
I downloaded the firmware using the command as explained in the guide ( git clone --recursive https://github.com/openmv/openmv.git), and build it without any changes to the downloaded firmware files (tried it 3 time using 2 different computers, having the same error after build and download).
Maybe some files are missing in the MicroPython…

  • Where can I find the entire MicroPython files required to the OpenMV project?
  • How should I update the submodules? (as you suggested)

@iabdalkader

Our Micropython fork is here, branch openmv-1.15

Shouldn’t need to do that if you clone with --recursive but:

git submodule update --init --recursive

I just tested cloning the repo from scratch and building the firmware and it everything is working fine.