Continual 'Exception: Could not find the file' error

I’m following this tutorial on EdgeImpulse regarding OpenMV image detection (https://docs.edgeimpulse.com/docs/tutorials/image-classification). Everything worked like a charm until this step (https://docs.edgeimpulse.com/docs/deployment/running-your-impulse-openmv). I followed the “Deploying your impulse as an OpenMV firmware” recommended method - downloaded the .zip, loaded the firmware for the correct model after download, erased internal file system, blue LED blinked, etc. When I ran the provided ei_image_classification.py, however, a “Could not find the file” error happened:

I followed the tutorial to the letter. Does anyone what’s causing this issue and how to solve it? Much appreciated!

Huh, the model is built into the firmware. So, I can’t check if it’s in the firmware… Please bring this up with EdgeImpulse support. If there was a problem it would be with how they built the firmware.

However, the only thing I can think of is that you didn’t somehow load the right firmware.

Note that there are two paths.

  1. Run the model from the internal flash with the model baked into the application image (best).
  2. Run the model from an SD card / internal FAT file system of the OpenMV Cam. This is more flexible but requires loading the model into RAM.