Cannot save to SD card

Hi,

I am trying to save video to the SD card using a H7+, as in the mjpeg example. However, it appears the SD card is not being detected by the camera during startup: the SD card is not visible when mounting the camera in windows, the camera does not run a main.py loaded there manually, and scripts run from the IDE save output to the internal flash. However, the card is visible when running

import pyb
sd=pyb.SDCard()
print(sd.present(), sd.info())

as recommended here, which showed that pyb.SDCard().present() was true. However, using uos.statvfs(’/’) showed that the root FS had only 8183 x 4096 byte blocks.

I also tried manually mounting, in accordance with the micropython documentation but this failed with errorno ENODEV.

It does not appear to be a hardware issue: the card works fine on my laptop’s own slot, but not in any H7 or HT+ I tried, and the card is a SanDisk Ultra 16GB C10 card (a type tested successfully here). I am using the latest firmware (4.3.0), but had the same problem before updating too, so I suspect the problem is user error somehow. What am I doing wrong?

When you connect the card to the camera and then plug the camera into the PC what disk shows up?

Is present just tests a GPIO pin… but, if the card file system cannot be mounted then it will not appear.

I see the internal flash when connected via USB.

I can write to the SD card using pyb.SDCard().writeblocks(), and then extract the data from the raw device file on a laptop, which makes me think that the problem is mounting the card, but I’ve tried both exFAT and FAT formats and neither worked

Any resolution on this one? seems to be the problem I have as well.