The rame buffer of ide become white like a paper

the rame buffer of ide become white like a paper when i turn on a circle light source of led 。
the light source of led looks like this:


so , i have to turn off the running code ,and restart a new running .
what 's wrong with the openmv?

Hi, you need to turn auto exposure and auto gain on. If you turned them off if your code the camera will not adjust to a changing scene.

thank you . if i want to find the red circle mark, and the docs of openmv says
set_auto_whitebal :“You need to turn off gain control too if you want to track colors.”
so, turn off or turn on ,which is the right? :cold_sweat:

That prevents the colors from changing given the scene. If the scene changes you want to turn it back on.

Items moving around in the scene can change the color gains. That’s why you want to turn it off. If it’s a scene change like the lighting then you want it on.

actureally ,the scene changes from one site to another site about 60cm distance ,and very site i will turn light on for 10 seconds。
i decide to turn on the set_auto_whitebal and set_auto_gain。is it right?

Yes, let them run each time the scene changes.

1 Like

i run my code with set_auto_whitebal and set_auto_gain of true, the while paper doesn’t appear.
thank you!