Raspberry 4 installation problems

Hi, i have a Problem…
I want to install openmv ide on my new raspberry 4 (Debian Buster with Raspberry Pi Desktop Version: 02.2020).
When I execute the file setup.sh the following text appears:


Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libpng-dev : Conflicts: libpng12-dev but 1.2.54-6 is to be installed
libpng12-dev : Conflicts: libpng-dev but 1.6.36-6 is to be installed
E: Unable to correct problems, you have held broken packages.
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: pyusb in /usr/local/lib/python2.7/dist-packages (1.0.2)
Could not find libts library

can anyone help me to solve the problem?

Does the IDE run however?

If you look into the setup script it’s just kicking off a lot of sudo apt-get installs which may or may not be available for the system.

I.e. you can ignore those errors.

Thank you for your answer.

No the ide doesn’t work:
pi@raspberrypi:~/Downloads/openmvide/bin $ ./openmvide
./openmvide: error while loading shared libraries: libGLESv2.so: cannot open shared object file: No such file or directory

Mmm, I’ve seen a similar error before. Try out following this: Games that uses libGLESv2.so doen't work in raspbian stretch - Raspberry Pi Forums

I have patched the IDE to work on a fresh Raspberry Pi 3 with the latest OS I have at home. I thought this error was fixed. Others encountered similar issues and fix their problem.

Really common issue: error while loading shared libraries: libGLESv2.so: cannot open shared object file: No such file or directory - Google Search

Hmm, yeah, I can assure you I’ve fixed this issue for the default RasberyPi OS image with a Pi 3. However, I’m not surprised the issue came back again… If once of these solutions works for you let me know and I’ll incorporate it into our setup.sh script.

Thank you for your answer.
Unfortunately my knowledge of Linux is insufficient to solve this problem.

It would be great if the installation file would work on a new Debian Buster installation (without tricks).

Best regards
Stefan

I have a Raspberry Pi 4 in the mail. It arrives this week. Will fix.

I have a Raspberry Pi 4 in the mail. It arrives this week. Will fix.

Hi,

I have the same problem than stefan broken dependencies:
Les paquets suivants contiennent des dépendances non satisfaites :
libpng-dev : Est en conflit avec: libpng12-dev mais 1.2.54-6 devra être installé
libpng12-dev : Est en conflit avec: libpng-dev mais 1.6.36-6 devra être installé

Is it an issue for this problem? (raspberry pi 4 debian buster 02/2020)

Thanks in advance for your answers.

Francois

Hi, this will be fixed in the next 2 weeks. We are doing an IDE release.

very nice, I’m so impatient.
Thank’s for your answer.

Having the same problem. Any update on this?
-Thanks

I have the Pi4, I will get on it.

The IDE is fine. I just have to fight through install issues and fix the setup.sh script that installs required libs.

Hi, i have a Problem…
I want to install openmv ide on my raspberry 3 (Debian Buster with Raspberry Pi Desktop last Version:).
When I execute the file setup.sh the following text appears:

The following packages have unmet dependencies:
libpng-dev : Conflicts: libpng12-dev but 1.2.54-6 is to be installed
libpng12-dev : Conflicts: libpng-dev but 1.6.36-6 is to be installed
E: Unable to correct problems, you have held broken packages.

can help me to install IDE OpenMV?

I figured out how to fix this. The issue will be resolved in the next IDE release.

Execute these steps here in the mean-time.

pi@raspberrypi:~/Downloads/openmvide $ python make.py
Traceback (most recent call last):
File “make.py”, line 299, in
make()
File “make.py”, line 255, in make
os.path.join(installdir, “lib/Qt/lib/fonts”))
File “/usr/lib/python2.7/shutil.py”, line 194, in copytree
names = os.listdir(src)
OSError: [Errno 2] No such file or directory: ‘/home/pi/Downloads/openmvide/dejavu-fonts/fonts/’

Ah, yeah, that part won’t work unless you have the ide install folder.

Please do this, edit you script to match what that file generates.

Ah, yeah, that part won’t work unless you have the ide install folder.

Please do this, edit you script to match what that file generates.

Hello! When to expect the next release for RPi, taking into account the fixes?

Next week. Just working on new LCD display code right now. I hope to get that done over the weekend. Then I’ll update the IDE.