OS error with OpenMV cam H7

Hi,
I have an OpenMV cam H7 (non plus) and I am trying to deploy a model trained with Edge Impulse. I have tried different models and got a model
small enough that can fit in the device. I have used a small image input (48x48) and a mobilenet V2 0.1.
I copied the tensorflow lite and labels files to the SD card and run the python code, but I always get OS error and no other info:

Traceback (most recent call last):
File “”, line 21, in
OSError:
MicroPython: v1.15-r57 OpenMV: v4.1.1 HAL: v1.9.0 BOARD: OPENMV4-STM32H743
Type “help()” for more information.

is there a way to get more debug/error info?

I am happy to upload the code (as a new user I can’t).

Thanks,
Matteo

Hi, I can’t tell what the error is. When the above is happening it means that the TensorFlow library did not return an error string for the error but just threw an error.

How is your model different from the normal TensorFlow models on edge impulse?

Hi @kwagyeman,
it is a fairly standard model created using transfer learning from edge impulse. Do you have any suggestions on how to upload the model? I can’t upload it to this message since I am a new user.

Thanks,
Matteo

Just put it in a zip file.

Hi @kwagyeman
unfortunately I can’t upload a file as new user.

I have uploaded it to gdrive model

Thanks and regards,
Matteo

Hi sorry, I don’t actually have any way of debugging this issue. The only thing I can offer is that we’re almost done porting to the new version of TF Lite. I don’t actually have any tools to determine what the error is either. However, the OpenMV Cam firmware is running an older version of TF Lite. So, I’m guessing the error is related to Edge Impulse updating their system.

I have this same exact issue. I have upgraded to windows 11 from windows 10 but idk why it specifically gives me the same traceback in the same line, line 21

how long until done porting to the new version of TF lite? I can try again then

I finished all the porting work. However, the latest version of it has segfaults in it. The person detector network does run 6x faster though.

I have to switch to a more stable branch again and I just haven’t found time. I hope to have time to do the changes and merge everything next week.