no file found

Hi,
It’s been along time.

I just pulled up an old script. It has the following command.
img=image.Image("/blksqrclose.pgm",copy_to_fb=True)
When i run the script I get the following error.
os error: could not find file
The file is located at c:\user\jimkim\documents\blksqrclose.pgm

Any ideas?
Thanks
Jim Sullivan

The script runs on the camera. You have to copy the image file to the camera. Make sure you have an SD card.

Hi,
I remember now.
Thanks,
Jim

My image is grey scale 640x480. When I look at properties on the K drive it lists capacity at 81KB . The 307KB picture cannot be copied to the K drive.
Jim

Please add an SD card. You can’t save images on the internal flash.

I have an SD card installed. How do I copy my image file to it?

Thanks
Jim

Use the PC to copy & paste and then umount and put the card in the camera, or put the card in the camera, connect to PC a driver will show up, copy & paste, unmount and reset the camera

I followed your instructions:
" or put the card in the camera, connect to PC a driver will show up, copy & paste, unmount and reset the camera"

I put the card “sandisk ultra plus 16gb” in the camera with the red tab of the card facing the same way as the camera.
I plugged in the USB connection from the camera into a PC USB port.
In Windows Explorer the following showed up under “Computer”—Removable disk (K)
Disk(K) has one file named .openmv_disk.
Disk(K) has 80,000 bytes of space.

Is it possible the SD card is corrupted, or that the CAM7 software is corrupted. I’m running version 3.3.1

Jim

Make sure the card is formatted to FAT or exFAT (exFAT is faster) and please upgrade the firmware.

I reloaded the firmware.
I checked the K drive properties. It uses the FAT file system. It has 80 KBYTES of memory available. It ran its self-test successfully.