Firmware upgrade on old M4 (2016) fails

I tried to upgrade my old M4 with the latest IDE and firmware, but after the process ran through there is only the white LED permanently flashing.
I did a downgrade to firmware 2.1 which worked. Any idea?


I also have this problem after updating my M4 firmware


Do you have an M4 with OV7725 or OV2640 ?

Mine is an OV7725


If an older firmware works we know the hardware is fine… Can you try upgrading to 3.3.1 ? I just tested my M4/OV7725 and it works fine. Also if you have an SD card please remove it.

I installed the latest IDE 2.2.0 and tried that firmware. Removing the SD card didn’t change anything.

I also tried the manual install (tools/bootloader file \OpenMV IDE\share\qtcreator\firmware\OPENMV2\openmv.dfu).

Okay I see the issue now, it happens when the internal filesystem is erased and the flash is formatted with the latest firmware. I’ll work on debugging this but for now there’s workaround if you want latest fw you can upload an older firmware image first (tested with 3.0) and check erase internal filesystem and then let the camera boot to create a fresh FS with the old firmware, and then update to the latest (3.3.1) but this time keep the internal fs.

Hi, the attached firmware should fix the issue. (560 KB)

Thanks. Your previous post actually solved the issue.

Best regards,

Tested new firmware on M4 OV7725 and now working.