LORA demo

Place for technical questions related to the Arduino Portenta H7.
resolver101757
Posts: 3
Joined: Wed Feb 17, 2021 3:10 pm

LORA demo

Postby resolver101757 » Wed Feb 17, 2021 3:30 pm

Hello,

I'm running the LORWan example and it runs and i can see the join messages hit the things network so i know its communicating.


However, I get the following message "could not open E:\lora.py for reading. Either the file does not exist or you do not have the permissions to open it." Click ok and it says LORAerrornoNetwork : command "+CTX" has failed!.

At the top of the script it says import LORA import *, where is this library located? Its not on the E drive. Is this part of the error.
User avatar
iabdalkader
Posts: 1326
Joined: Sun May 24, 2015 3:53 pm

Re: LORA demo

Postby iabdalkader » Wed Feb 17, 2021 3:54 pm

No the error is this:
LoraErrorNoNetwork : command "+CTX" has failed

The IDE just can't open the library file to show the line number because the library is builtin, this is unrelated.
User avatar
kwagyeman
Posts: 5001
Joined: Sun May 24, 2015 2:10 pm

Re: LORA demo

Postby kwagyeman » Wed Feb 17, 2021 4:37 pm

I need to fix this in the way the IDE works. If it can't open a file that's supposed to be on the disk then it should just not display that error.
Nyamekye,
resolver101757
Posts: 3
Joined: Wed Feb 17, 2021 3:10 pm

Re: LORA demo

Postby resolver101757 » Thu Feb 18, 2021 5:08 am

Thanks for replying so quick :-) When you say the library is built in, do you mean it is hidden, can it be viewed? I wouldnt mind understand more about it.

In terms of the error, i guess i need to wait until its fixed by openmv?
User avatar
iabdalkader
Posts: 1326
Joined: Sun May 24, 2015 3:53 pm

Re: LORA demo

Postby iabdalkader » Thu Feb 18, 2021 9:49 am

You can view the library here, you can also download it and copy it to the storage and make changes if needed.

https://github.com/openmv/openmv/blob/m ... es/lora.py

There's nothing to fix, seems the error says the network is not found for some reason. I'm not an expert on LoRa and I don't have any LoRa hardware to test with, so you'll have to figure it out and if you do find any bugs send us a PR.


EDIT: You may also find more help on Arduino's forums.
resolver101757
Posts: 3
Joined: Wed Feb 17, 2021 3:10 pm

Re: LORA demo

Postby resolver101757 » Sat Feb 20, 2021 6:57 am

OK, confirmed, not a software issue. The device wasn't getting a signal from the room i was testing in, week signal. Hanged the device out of the window and worked. I probably need to capture the error and display a better message so know what it means :-)


For anyone else reading, I've got good signal from other devices, so I need to look at better antenna...

Return to “Arduino Portenta H7”

Who is online

Users browsing this forum: No registered users and 1 guest