Page 1 of 1

Newly bought Wifi Shield hanged

Posted: Wed Sep 13, 2017 10:19 am
by Ablon
I recently bought a Wifi Shield and tried all the sample Wifi codes from the IDE but all of them hanged. Ran other sample codes that never use Wifi Shield with the Wifi Shield attached, no issue. Anyone has experienced with the Wifi Shield?

Re: Newly bought Wifi Shield hanged

Posted: Wed Sep 13, 2017 12:02 pm
by kwagyeman
Ibrahim any debug suggestions on this?

Re: Newly bought Wifi Shield hanged

Posted: Thu Sep 14, 2017 3:05 am
by mjs513
I had a similar issue where the wifi shield would hang at trying to connect to the network. If this is the issue you are having try changing the port from 8080 to 80. You didn't really make it clear where it was hanging. Were you getting any messages printed - did the scan network sketch work? If nothing worked at all is the shield plugged in the right way? The only other time mine didn't work at all was when I shorted something and had to order another one.

Re: Newly bought Wifi Shield hanged

Posted: Thu Sep 14, 2017 11:11 am
by iabdalkader
Hi,

When you run scan.py you should see the WiFi firmware version printed:

Code: Select all

Firmware version: (19, 4, 4, 19, 3, 0, 1377184)
If you don't see that and the cam gets stuck/hangs, it means the shield HW is bad.

Re: Newly bought Wifi Shield hanged

Posted: Thu Sep 14, 2017 11:29 am
by kwagyeman
The poster emailed us about this. They found that the spi pins were shorted. MacroFab manually solders these shields... So, sometimes they short the ground plane to the pins. The next batch will not have headers soldered on.

Re: Newly bought Wifi Shield hanged

Posted: Sat Sep 23, 2017 12:08 pm
by rocketman
Hi,

I am having same issue. This is the output from my wifi shield:

Thanks!

Re: Newly bought Wifi Shield hanged

Posted: Sat Sep 23, 2017 5:56 pm
by kwagyeman
Can you post a high res picture? I'll take a look and send you a replacement if I see the shorting issue.

Re: Newly bought Wifi Shield hanged

Posted: Sat Sep 23, 2017 6:21 pm
by rocketman
I assume of the board? Attached.

Looking forward to your reply.

Re: Newly bought Wifi Shield hanged

Posted: Sat Sep 23, 2017 10:57 pm
by kwagyeman
Hi, do you see any shorts on the module pins to other pads? I can't tell from the image. We've seen issues with the module not soldering correctly.

Re: Newly bought Wifi Shield hanged

Posted: Sun Sep 24, 2017 11:54 am
by rocketman
I don't think so...but I am no expert and its very hard to tell. Can you forward a new module?

Re: Newly bought Wifi Shield hanged

Posted: Sun Sep 24, 2017 5:53 pm
by kwagyeman
Yes, email us with you info. Please also attach your telephone number if you are not in the US.

Re: Newly bought Wifi Shield hanged

Posted: Mon Nov 20, 2017 1:58 pm
by rommel
Hi, just wanted to add info from my experience with the WiFi shield.

I ordered one and have seen and verified (with meter) that some pins of the ATWINC1500 module are shorted. It is caused by the ATWINC1500 module not being perfectly aligned to the wifi shield pads. So some of the ATWINC1500 module pins would touch multiple pads on the wifi shield.

:geek: :ugeek:

Re: Newly bought Wifi Shield hanged

Posted: Mon Nov 20, 2017 11:15 pm
by kwagyeman
Please contact us for a replacement if this is the case.