New M7 not detected over USB

Discussion related to "under the hood" OpenMV topics.
allengregoryiv
Posts: 2
Joined: Wed May 24, 2017 10:27 pm

New M7 not detected over USB

Postby allengregoryiv » Wed May 24, 2017 10:30 pm

I bought two M7s one of them seems to be working and the IDE can connect to it and windows recognizes it fine.

The other one isn't recognized by windows when using the same USB cable. It just says that the USB device isn't recognized and to try to plug it in again.

Any suggestions?
User avatar
kwagyeman
Posts: 4269
Joined: Sun May 24, 2015 2:10 pm

Re: New M7 not detected over USB

Postby kwagyeman » Wed May 24, 2017 11:05 pm

Mmm, okay, try to put it in DFU mode. If that doesn't work there's an issue with the USB connector...

(This is second time we've gotten a customer saying the USB connector is bad - for the next OpenMV Cam production run i will require each cam to be plugged into a PC before it passes Q.C. versus it just passing Q.C. with our programming jig...)

To put the camera into DFU mode do this:
Image

And then plug it into your PC and you should see a DFU device (in windows):
Image

If that doesn't work please send us an email with your shipping address, phone number, and receipt, and we'll send you a replacement.
Attachments
2.png
2.png (6.71 KiB) Viewed 4293 times
1.jpg
1.jpg (32.54 KiB) Viewed 4293 times
Nyamekye,
allengregoryiv
Posts: 2
Joined: Wed May 24, 2017 10:27 pm

Re: New M7 not detected over USB

Postby allengregoryiv » Wed May 24, 2017 11:09 pm

Just tested, with the jumper it still says device not recognized but the camera doesn't flash any of it's LEDs like it normally does.
User avatar
kwagyeman
Posts: 4269
Joined: Sun May 24, 2015 2:10 pm

Re: New M7 not detected over USB

Postby kwagyeman » Thu May 25, 2017 12:16 am

K, send us a email with the info above. You might be able to fix the camera by applying a heat gun to the USB connector for a few seconds.
Nyamekye,
tinito
Posts: 1
Joined: Mon May 29, 2017 5:06 am

Re: New M7 not detected over USB

Postby tinito » Mon May 29, 2017 5:09 am

kwagyeman wrote:
Wed May 24, 2017 11:05 pm
Mmm, okay, try to put it in DFU mode. If that doesn't work there's an issue with the USB connector...

(This is second time we've gotten a customer saying the USB connector is bad - for the next OpenMV Cam production run i will require each cam to be plugged into a PC before it passes Q.C. versus it just passing Q.C. with our programming jig...)
Third one here!

I've just received the OpenMV M7 camera and it does not enumerate, both in normal operations and in bootloader mode.

I'm running Ubuntu 16.04 and I work with several STM32 microcontrollers without any problem in enumerating their USB ports, here the dmesg output after I connect the camera:

Code: Select all

[1476382.168489] usb 3-4: new full-speed USB device number 75 using xhci_hcd
[1476382.168637] usb 3-4: Device not responding to setup address.
[1476382.372633] usb 3-4: Device not responding to setup address.
[1476382.576473] usb 3-4: device not accepting address 75, error -71
[1476382.576514] usb usb3-port4: unable to enumerate USB device
How should I proceed?
User avatar
kwagyeman
Posts: 4269
Joined: Sun May 24, 2015 2:10 pm

Re: New M7 not detected over USB

Postby kwagyeman » Mon May 29, 2017 12:38 pm

You emailed us. We'll take care of this from there.

Um, as for a check, can you test the system on a windows machine? If the USB were bad you should see any action right?
Nyamekye,
ckshobha
Posts: 2
Joined: Wed Dec 04, 2019 10:58 pm

Re: New M7 not detected over USB

Postby ckshobha » Wed Dec 04, 2019 11:13 pm

I am also facing the same issue

New H7 not mounting on Ubunut 18.04/MAC OSX 10.14/windows 10

Although I see LED light flashing green on connect and then flashing blue but it does not show up on the system.
I tried the following steps mentioned in this thread and still do not see any device under the USB controller on window
viewtopic.php?t=293

Please suggest what should be done?

Thanks
Shobha
User avatar
kwagyeman
Posts: 4269
Joined: Sun May 24, 2015 2:10 pm

Re: New M7 not detected over USB

Postby kwagyeman » Thu Dec 05, 2019 3:19 am

Please verify that the USB cable provides data also by hooking up your phone or other device through it.
Nyamekye,
ckshobha
Posts: 2
Joined: Wed Dec 04, 2019 10:58 pm

Re: New M7 not detected over USB

Postby ckshobha » Thu Dec 05, 2019 8:33 pm

Thanks. Using a data cable worked.

Return to “Technical Discussion”

Who is online

Users browsing this forum: No registered users and 10 guests