WiFi shield firmware

Discussion related to "under the hood" OpenMV topics.
Capstan
Posts: 21
Joined: Tue Nov 12, 2019 11:04 am

WiFi shield firmware

Postby Capstan » Sun Dec 01, 2019 11:36 am

I installed the IDE yesterday and can connect to a H7 board with no problem, updated the firmware.

I have a WiFi shield plugged in to the H7 board and am trying to run the connect.py script from the IDE. I get an error;
OSError: Failed to initialize WINC1500 module: Firmware version mismatch. Please update WINC1500 firmware, see Examples->14-WiFi-Shield->fw_update.py

fw_update.py says;

Code: Select all

# Firmware is at <openmv-ide-install-dir>/share/qtcreator/firmware/WINC1500/winc_19_6_1.bin
and later in the script...

Code: Select all

# For ATWINC1500-MR210PB only.
wlan.fw_update("/winc_19_6_1.bin")
But when I look in that .../firmware/WINC1500 directory I see winc_19_5_2.bin, there is no 6_1 file. I tried copying the winc_19_5_2.bin file to the base directory of the H7 flash drive and changed the script to load that. It appeared to run an update but I still get the mismatch message.

Code: Select all

wlan = network.WINC(mode=network.WINC.MODE_FIRMWARE)
print("\nFirmware version:", wlan.fw_version())
)
result is; Firmware version: (0, 0, 0, 0, 0, 0, 0

That's troubling because it may mean that the H7 isn't really communicating with the WiFi shield. I assume this happens over SPI? I am pretty sure I have the shield mounted on the H7 board correctly?
https://postimg.cc/dkFbP3mc
Capstan
Posts: 21
Joined: Tue Nov 12, 2019 11:04 am

Re: WiFi shield firmware

Postby Capstan » Sun Dec 01, 2019 1:11 pm

Looking around at the various threads I saw that there was new firmware available so I downloaded that and unzipped it;
https://github.com/openmv/openmv/releas ... 5.0.beta.3

Did a search there and found a winc_19_6_1.bin file. So I put that on the H7 flash base directory and ran fw_update.py, afterwards the connect.py script ran with no problem.

So I am suspecting that the IDE install package has not been updated to include the required winc_19_6_1.bin file.
User avatar
iabdalkader
Posts: 1193
Joined: Sun May 24, 2015 3:53 pm

Re: WiFi shield firmware

Postby iabdalkader » Sun Dec 01, 2019 1:19 pm

>> So I am suspecting that the IDE install package has not been updated to include the required winc_19_6_1.bin file.

Yes I think it's missing from the current IDE resources, just saw your second reply I assume it's working now.
Capstan
Posts: 21
Joined: Tue Nov 12, 2019 11:04 am

Re: WiFi shield firmware

Postby Capstan » Sun Dec 01, 2019 1:24 pm

Yes it is working now, thanks.

Return to “Technical Discussion”

Who is online

Users browsing this forum: No registered users and 22 guests