Page 1 of 1

no file found

Posted: Fri Oct 25, 2019 10:58 am
by pcls1026
Hi,
It's been along time.

I just pulled up an old script. It has the following command.
img=image.Image("/blksqrclose.pgm",copy_to_fb=True)
When i run the script I get the following error.
os error: could not find file
The file is located at c:\user\jimkim\documents\blksqrclose.pgm

Any ideas?
Thanks
Jim Sullivan

Re: no file found

Posted: Fri Oct 25, 2019 11:30 am
by kwagyeman
The script runs on the camera. You have to copy the image file to the camera. Make sure you have an SD card.

Re: no file found

Posted: Fri Oct 25, 2019 2:20 pm
by pcls1026
Hi,
I remember now.
Thanks,
Jim

Re: no file found

Posted: Fri Oct 25, 2019 2:44 pm
by pcls1026
My image is grey scale 640x480. When I look at properties on the K drive it lists capacity at 81KB . The 307KB picture cannot be copied to the K drive.
Jim

Re: no file found

Posted: Fri Oct 25, 2019 5:46 pm
by kwagyeman
Please add an SD card. You can't save images on the internal flash.

Re: no file found

Posted: Sat Oct 26, 2019 1:02 pm
by pcls1026
I have an SD card installed. How do I copy my image file to it?

Thanks
Jim

Re: no file found

Posted: Sat Oct 26, 2019 1:23 pm
by iabdalkader
pcls1026 wrote:
Sat Oct 26, 2019 1:02 pm
I have an SD card installed. How do I copy my image file to it?

Thanks
Jim
Use the PC to copy & paste and then umount and put the card in the camera, or put the card in the camera, connect to PC a driver will show up, copy & paste, unmount and reset the camera

Re: no file found

Posted: Sun Oct 27, 2019 6:16 pm
by pcls1026
I followed your instructions:
" or put the card in the camera, connect to PC a driver will show up, copy & paste, unmount and reset the camera"

I put the card "sandisk ultra plus 16gb" in the camera with the red tab of the card facing the same way as the camera.
I plugged in the USB connection from the camera into a PC USB port.
In Windows Explorer the following showed up under "Computer"---Removable disk (K)
Disk(K) has one file named .openmv_disk.
Disk(K) has 80,000 bytes of space.

Is it possible the SD card is corrupted, or that the CAM7 software is corrupted. I'm running version 3.3.1

Jim

Re: no file found

Posted: Mon Oct 28, 2019 11:52 am
by iabdalkader
Make sure the card is formatted to FAT or exFAT (exFAT is faster) and please upgrade the firmware.

Re: no file found

Posted: Wed Oct 30, 2019 10:41 am
by pcls1026
I reloaded the firmware.
I checked the K drive properties. It uses the FAT file system. It has 80 KBYTES of memory available. It ran its self-test successfully.