no file found

Discussion related to "under the hood" OpenMV topics.
pcls1026
Posts: 123
Joined: Tue Aug 22, 2017 1:33 am

no file found

Postby pcls1026 » Fri Oct 25, 2019 10:58 am

Hi,
It's been along time.

I just pulled up an old script. It has the following command.
img=image.Image("/blksqrclose.pgm",copy_to_fb=True)
When i run the script I get the following error.
os error: could not find file
The file is located at c:\user\jimkim\documents\blksqrclose.pgm

Any ideas?
Thanks
Jim Sullivan
User avatar
kwagyeman
Posts: 4268
Joined: Sun May 24, 2015 2:10 pm

Re: no file found

Postby kwagyeman » Fri Oct 25, 2019 11:30 am

The script runs on the camera. You have to copy the image file to the camera. Make sure you have an SD card.
Nyamekye,
pcls1026
Posts: 123
Joined: Tue Aug 22, 2017 1:33 am

Re: no file found

Postby pcls1026 » Fri Oct 25, 2019 2:20 pm

Hi,
I remember now.
Thanks,
Jim
pcls1026
Posts: 123
Joined: Tue Aug 22, 2017 1:33 am

Re: no file found

Postby pcls1026 » Fri Oct 25, 2019 2:44 pm

My image is grey scale 640x480. When I look at properties on the K drive it lists capacity at 81KB . The 307KB picture cannot be copied to the K drive.
Jim
User avatar
kwagyeman
Posts: 4268
Joined: Sun May 24, 2015 2:10 pm

Re: no file found

Postby kwagyeman » Fri Oct 25, 2019 5:46 pm

Please add an SD card. You can't save images on the internal flash.
Nyamekye,
pcls1026
Posts: 123
Joined: Tue Aug 22, 2017 1:33 am

Re: no file found

Postby pcls1026 » Sat Oct 26, 2019 1:02 pm

I have an SD card installed. How do I copy my image file to it?

Thanks
Jim
User avatar
iabdalkader
Posts: 1193
Joined: Sun May 24, 2015 3:53 pm

Re: no file found

Postby iabdalkader » Sat Oct 26, 2019 1:23 pm

pcls1026 wrote:
Sat Oct 26, 2019 1:02 pm
I have an SD card installed. How do I copy my image file to it?

Thanks
Jim
Use the PC to copy & paste and then umount and put the card in the camera, or put the card in the camera, connect to PC a driver will show up, copy & paste, unmount and reset the camera
pcls1026
Posts: 123
Joined: Tue Aug 22, 2017 1:33 am

Re: no file found

Postby pcls1026 » Sun Oct 27, 2019 6:16 pm

I followed your instructions:
" or put the card in the camera, connect to PC a driver will show up, copy & paste, unmount and reset the camera"

I put the card "sandisk ultra plus 16gb" in the camera with the red tab of the card facing the same way as the camera.
I plugged in the USB connection from the camera into a PC USB port.
In Windows Explorer the following showed up under "Computer"---Removable disk (K)
Disk(K) has one file named .openmv_disk.
Disk(K) has 80,000 bytes of space.

Is it possible the SD card is corrupted, or that the CAM7 software is corrupted. I'm running version 3.3.1

Jim
User avatar
iabdalkader
Posts: 1193
Joined: Sun May 24, 2015 3:53 pm

Re: no file found

Postby iabdalkader » Mon Oct 28, 2019 11:52 am

Make sure the card is formatted to FAT or exFAT (exFAT is faster) and please upgrade the firmware.
pcls1026
Posts: 123
Joined: Tue Aug 22, 2017 1:33 am

Re: no file found

Postby pcls1026 » Wed Oct 30, 2019 10:41 am

I reloaded the firmware.
I checked the K drive properties. It uses the FAT file system. It has 80 KBYTES of memory available. It ran its self-test successfully.

Return to “Technical Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests