Page 1 of 1

openmv-ide requirements

Posted: Thu Nov 19, 2020 1:16 pm
by koendv
openmv-ide is qtcreator with an extra plugin added. qtcreator is a qt app. You can compile qt apps for android. Does this mean you could compile openmv-ide as an android app?
What would be necessary to run openmv-ide on an android phone?

Re: openmv-ide requirements

Posted: Thu Nov 19, 2020 1:19 pm
by kwagyeman
While this is technically possible we use a lot of desktop services. I don't think you can actually get the IDE running on a phone. What you can do however it take out the I/O layer easily and integrate it into an Android app. I.e. write a new UI and you can reuse a lot of the programming and loading code.