H7 Plus custom board - cannot connect flash blinking blue

I have a custom H7 plus board which already had working but changed flash and sdram to different PN in theory compatible. W25Q256JVEIQ and IS42S32800J-6TL.

I manage to load the firmware however when I plug in the Openmv I hear the device USB device enumerate, quickly see the USB symbol on the connect button and then it disappears. LED flashes blue at a high frequency I guess 10 Hz. Not slow blinking blue as usual when openmv is on waiting for connection.

Does anybody know what flash blinking blue means so I can debug?

You may need to fix the SDRAM timings in the firmware. If they are different then the SDRAM may not work causing memory corruption. micropython/mpconfigboard.h at 2bbe0bcb7ed7103fdd808d1332aaeef10a44064e · openmv/micropython · GitHub

Good to know thanks. I was told by the manufacturer that IS42S32800J-6TL was form fit function replaceable part for obsolete IS42S32800B-6T. Is it the case that MICROPY_HW_SDRAM_TIMING_TMRD (2) means CAS Latency 2 for the newer chip (see table) and is actually correct?
image

Hi, the numbers in the code are in the units of 10nsec. What must be true is that they are larger or equal to values in the datasheet.

Thanks. Do you have experience with that chip I mention being the other is obsolete and if so do you know as a fact that I need to change the timings? I would approcciate if you let me know as I have a bit of a “situation” which I need to solve quickly.

Could take days to figure out and it might be the problem is elsewhere.

Thanks.

Hi, I provided the information you need to check the calculations. Please do not ask me to provide help support for your custom product.

Sorry I thought OpenMV was a hw/sw development board and this forum was to help with new projects.

It is, but, you asked me to run the calculations for you on it versus asking me to double check. I provided the link to the values that need to be confirmed and told you how to do it.

Sorry I didn’t and never would ask you to run calculations. Was asking if you used that chip before and knew that it wasn’t form fit function compatible without having to change firmware.

In the meantime I managed to connect to the OpenMV via pc by loading an older firmware version 3.9.2. No blinking blue light.

When I try to connect I am prompted to upgrade firmware . If I don’t I can connect and do stuff. I tried to access sdram and I get a failure not enough memory . So indeed the timing is probably an issue.

Hi,
I am using a different part too, as the previous one is obsolete, and I suspect I am running into a similar issue.
Is it possible to clarify the meaning of the different timing constants in micropython/mpconfigboard.h at 2bbe0bcb7ed7103fdd808d1332aaeef10a44064e · openmv/micropython · GitHub so it can be adapted to different SDRAM timings?

Regards

Sigh, please post the datasheet links and I’ll run the numbers for you. It’s simple to do but hard to explain unless you research what they are.

IS42S32800J-6TL @ercasta do you use the same?. The manufacturer even sent me samples and said was identical to IS42S32800B-6T.

With 3.9.2 firmware you can connect at least with IDE. With 3.9.4 up you get the fast blue light upon power on. I think the “Fix linker script stack allignment for boards with SRAM” might be making some checks and panics when it doesn’t find the sdram. Tomorrow I will try to compile without that change and tell you what I get.

Hi, I checked all the numbers and they are fine. It’s identical. All the firmware timings for the SDRAM are fine.

At line 127 you can disable the self check a run the openmv normally (without SDRAM) . I tried with slower timings, no luck. You?

Sorry, I haven’t been able to try yet. Please let me know if you solve the issue, I’m using the same component.

Friday I’m getting two of the same boards , one with the old flash and one with the new one. Could be I got unlucky with the bga. How many boards do you have with same configuration?

Hello, I have built an identical board with the obsolete SRAM. It works. The two chips should be identical according to the manufacturer. @kwagyeman any hints? If you are intending to make more H7plus and cannot find that obsolete chip, we can help.

I don’t know why it doesn’t work. All the parameters match. Maybe your board construction is wrong?