Connecting OpenMV to RaspberryPi interrupts execution


I created script which reads barcode and sends it’s value to PC via USB virtual comm port.
Script works well if I connect camera to PC running Windows or old Slackware Linux.
But if I connect camera to RaspberryPi (Raspbian) or PC with Linux Mint autostart is stopped.
Looks like Raspbian/Linux Mint sends to camera something that stops execution while initialising kernel drivers.
Does anyone have similar problem solved?

You need to turn off ctrl c as an interrupt to the usb vcp port. See the usb vcp class and set the interrupt char.

Thanks for response!
I a also have disabled interrupt


, so this is not a case.

But Your response pointed me to recheck all I do, and I found that in my case problem is very simple: I missed error handling when using


function. Script crashes when in driver initialising time receives un-decodable Unicode.

Problem solved!

Thank You!

hi, I think u will know the answer,
I want to send an image from openmv cam to Raspberry pi after that I should stock it in the database in my case SQLite.
the problem is I’m new to the openMv world and i need some help to edit the code