Search found 4105 matches

by kwagyeman
Fri Aug 26, 2016 11:36 am
Forum: Technical Discussion
Topic: Hw reset and/or reboot?
Replies: 12
Views: 9540

Re: Hw reset and/or reboot?

Yes, just ground the RST pin. The BOOT pin controls if the default STM DFU bootloader turns on. The STM bootloader allows you to get out of being bricked if the flash gets completely corrupted.
by kwagyeman
Fri Aug 26, 2016 11:14 am
Forum: General Topics
Topic: Presence detection
Replies: 13
Views: 11062

Re: Presence detection

If the objects are in fixed positions you can then just use frame differencing with image masking. So, basically, you'd just difference the current image against a background image and then you'd apply a mask to zero out all the areas of the image you're not interested in. You can have a background/...
by kwagyeman
Wed Aug 24, 2016 6:50 pm
Forum: General Topics
Topic: Presence detection
Replies: 13
Views: 11062

Re: Presence detection

No that's fine. I'm just saying the thread owner will not respond. Anyway, please expand on your last paragraph. What do you mean?
by kwagyeman
Wed Aug 24, 2016 3:47 pm
Forum: Project Discussion
Topic: Mount SD Card
Replies: 3
Views: 3312

Re: Mount SD Card

Yeah, you have to use another card then. 64 GB cards are sdxc only. Pretty sure no MCUs will support that right now. We support and and sdhc which are less than 32gb in size. Mmm, now that's a problem. MCUs don't support sdxc. Not sure what to do about that. It's a hardware limitation too. Then stm3...
by kwagyeman
Wed Aug 24, 2016 2:20 pm
Forum: Project Discussion
Topic: Mount SD Card
Replies: 3
Views: 3312

Re: Mount SD Card

Can you try to format the SD card as a fat 32 volume? The firmware is not really robust just yet so it likely crashes when something is wrong.
by kwagyeman
Tue Aug 23, 2016 9:35 am
Forum: Technical Discussion
Topic: Catching the IDE "stop" in uPython
Replies: 2
Views: 2244

Re: Catching the IDE "stop" in uPython

It resets the scripts outside of uPython control. Anyway, we are about to do a release. Maybe Ibrahim can add something you need. Can you describe it?
by kwagyeman
Tue Aug 23, 2016 9:33 am
Forum: General Topics
Topic: Presence detection
Replies: 13
Views: 11062

Re: Presence detection

This was an old post. :)
by kwagyeman
Sun Aug 21, 2016 1:17 pm
Forum: General Topics
Topic: SD Card Size Recommendation
Replies: 5
Views: 4901

Re: SD Card Size Recommendation

Yeah, that's happened to me too. Pretty sure that's a bug. Weirdly, I believe the issue is buried in the MP code. Ibrahim will have to fix this.
by kwagyeman
Sun Aug 21, 2016 12:46 pm
Forum: General Topics
Topic: SD Card Size Recommendation
Replies: 5
Views: 4901

Re: SD Card Size Recommendation

The camera should support FAT32. Try deleting the volume and re-creating another FAT32 volume but limit the size to 2GB. The Micro Controller supports SDHC and we're using a library that supports SDHC but I think there might be some weird issue that needs to be debugged to get higher than 2GB working.
by kwagyeman
Sun Aug 21, 2016 11:15 am
Forum: Project Discussion
Topic: Case for OpemMV Camera
Replies: 1
Views: 2616

Re: Case for OpemMV Camera

Cool, thanks!
by kwagyeman
Thu Aug 18, 2016 4:39 pm
Forum: Technical Discussion
Topic: Time Lag for Image Acquisition
Replies: 8
Views: 4004

Re: Time Lag for Image Acquisition

What exactly are you trying to do? I can advise better if I know more.
by kwagyeman
Tue Aug 16, 2016 10:01 am
Forum: Technical Discussion
Topic: Using SD card while in IDE
Replies: 4
Views: 3340

Re: Using SD card while in IDE

Yes, please make one. Ibrahim needs to get on this. We've been moving things around in the firmware to free up RAM and he's trying to remove the flash buffer (16KB) so that we can have a separate JPEG buffer for IDE streaming.
by kwagyeman
Tue Aug 16, 2016 12:24 am
Forum: Technical Discussion
Topic: Using SD card while in IDE
Replies: 4
Views: 3340

Re: Using SD card while in IDE

Hi, you shouldn't be encounter in such problems. Um, try reformatting you as card for fat32. If the SD card is NTFS then the OpenMV cam can't read it. Also, use a less than 2gb SD card if possible.
by kwagyeman
Tue Aug 16, 2016 12:22 am
Forum: Technical Discussion
Topic: Broken USB conector
Replies: 6
Views: 4038

Re: Broken USB conector

Once we have enough funds to do a re order. We have to sell off all the cameras we have in stock right now. The whole Kickstarter fiasco only left one viable path for us.

Good news is that we've finally shipped cams to Lextronic and hopefully we will be selling quickly in Europe.
by kwagyeman
Mon Aug 15, 2016 12:06 pm
Forum: Technical Discussion
Topic: Broken USB conector
Replies: 6
Views: 4038

Re: Broken USB conector

We will be switching to another MicroUSB connector with holes that go through the board. We... had already paid for 1500 of these connectors last year before the new board rev so we had to use them. For the next set of boards we plan to build we will use a connector with more stress relief along wit...
by kwagyeman
Tue Aug 09, 2016 8:16 pm
Forum: Technical Discussion
Topic: Detect motion direction
Replies: 9
Views: 5482

Re: Detect motion direction

Can you let me know exactly what you want to do? I'll be able to give a better explanation of the steps you have to take then.
by kwagyeman
Tue Aug 09, 2016 11:51 am
Forum: Technical Discussion
Topic: Unable to connect and no blue heartbeat
Replies: 4
Views: 2718

Re: Unable to connect and no blue heartbeat

Hi, um, so please see the wiki post about installing the firmware dev environment. However, it looks like your on Mac which we don't have an tooling for. If possible, can you find a Windows PC? There's a wiki post about how to program the OpenMV Cam using Windows and STMs DFU programmer tool.
by kwagyeman
Mon Aug 08, 2016 11:49 pm
Forum: Technical Discussion
Topic: Changing Brightness (more brightness settings)
Replies: 5
Views: 3687

Re: Changing Brightness (more brightness settings)

Use the write reg function to set registers.
by kwagyeman
Mon Aug 08, 2016 5:14 pm
Forum: Technical Discussion
Topic: Unable to connect and no blue heartbeat
Replies: 4
Views: 2718

Re: Unable to connect and no blue heartbeat

Yes, please the OpenMV wiki on our OpenMV github account on how to reflash the firmware. I'll post a more detailed response when I get home.
by kwagyeman
Fri Aug 05, 2016 12:38 pm
Forum: General Topics
Topic: Suggestions for aquarium water level project
Replies: 5
Views: 5134

Re: Suggestions for aquarium water level project

Oh, okay, I understand. Mmm, so, color tracking is what you want to use for this. So, the first step will be to mount the camera such that it can see the area you want to see of the tank. You need to have a fixed mounting setup. Next, what's the color difference between the empty tank and non empty ...
by kwagyeman
Thu Aug 04, 2016 7:20 pm
Forum: General Topics
Topic: Suggestions for aquarium water level project
Replies: 5
Views: 5134

Re: Suggestions for aquarium water level project

Hi, can you describe exactly what you'd like to do. E.g. what feature of the cam will you use to detect the water level?
by kwagyeman
Tue Aug 02, 2016 11:24 pm
Forum: Technical Discussion
Topic: Changing Brightness (more brightness settings)
Replies: 5
Views: 3687

Re: Changing Brightness (more brightness settings)

Um, are you using the OV7725 camera?

Anyway, just use this function: https://openmv.io/docs/library/omv.imag ... mage.morph

You can adjust the image brightness/contrast with it.
by kwagyeman
Tue Aug 02, 2016 9:28 pm
Forum: General Topics
Topic: Building from scratch
Replies: 11
Views: 6784

Re: Building from scratch

Doesn't really look like our sensor. You might want to buy one of the OpenMV Cam's on our store as a reference. Here's the data sheet.

http://www.haoyuelectronics.com/Attachm ... (V1.2).pdf
by kwagyeman
Sun Jul 31, 2016 10:19 pm
Forum: General Topics
Topic: Building from scratch
Replies: 11
Views: 6784

Re: Building from scratch

Use the latest ones from GitHub.
by kwagyeman
Sun Jul 31, 2016 6:13 pm
Forum: General Topics
Topic: Building from scratch
Replies: 11
Views: 6784

Re: Building from scratch

It's probably not updated. Except for the camera sensor not much has changed. You can spec out all the parts from the schematic.

(Yes, sorry about it not being perfect - other higher priority stuff to work on).
by kwagyeman
Sun Jul 31, 2016 4:07 pm
Forum: General Topics
Topic: Building from scratch
Replies: 11
Views: 6784

Re: Building from scratch

Sure, but, note, the OV2640 is garbage. We use the OV7725 now. Read our KickStarter updates for why on that statement.

Our firmware should still support the OV2640 however.
by kwagyeman
Sun Jul 31, 2016 3:35 pm
Forum: General Topics
Topic: Building from scratch
Replies: 11
Views: 6784

Re: Building from scratch

Yes
by kwagyeman
Sat Jul 30, 2016 11:16 pm
Forum: General Topics
Topic: Building from scratch
Replies: 11
Views: 6784

Re: Building from scratch

Sorry for getting back to you so late. Been busy. So, you're free to try to do this. However, we source the camera directly from the manufacturer at 1500 pieces at a time. So... I'm not sure how you are going to get your hands on one. Additionally, the lenses and lens mounts are not on DigiKey/Mouse...
by kwagyeman
Sat Jul 30, 2016 1:29 pm
Forum: Technical Discussion
Topic: Hardware Version Identifier
Replies: 1
Views: 1738

Re: Hardware Version Identifier

All cameras use the same firmware right now. This is the OMV 2 firmware.

Please flash using the OpenMV.dfu or OpenMV.bin.

I'm working in the bootloader for the new IDE so this will be automated soon.
by kwagyeman
Tue Jul 19, 2016 8:17 pm
Forum: Technical Discussion
Topic: WIFI Shield not working
Replies: 3
Views: 2913

Re: WIFI Shield not working

I think you need to update the firmware to fix this problem. I just encountered it with version 1.4. try version 1.5.

I don't have a computer at the moment so I can't check.
by kwagyeman
Mon Jul 18, 2016 12:08 pm
Forum: Technical Discussion
Topic: Using the I2C protocol
Replies: 18
Views: 10759

Re: Using the I2C protocol

Ibrahim will have to take a look at this. It's highly likely there's a firmware bug for this. And... if there's a bug a firmware fix can be put out very quickly.
by kwagyeman
Sun Jul 17, 2016 6:29 pm
Forum: Technical Discussion
Topic: Using the I2C protocol
Replies: 18
Views: 10759

Re: Using the I2C protocol

Are you using the correct i2c bus? I tested out the i2c functions with an eeprom and they worked.

I won't have acess to a desktop PC until later this week so this is about the best I can help.
by kwagyeman
Sun Jul 17, 2016 9:27 am
Forum: Technical Discussion
Topic: What script runs when you power on the board?
Replies: 5
Views: 3972

Re: What script runs when you power on the board?

Guess your Linux system doesn't have the SQL light driver. I'm not using that part of QtCreator right now. I will comment out that code. All settings are stored in an ini file right now. The SQL code is for a secondary database that stores more settings. Those links will be posted in a KickStarter u...
by kwagyeman
Sat Jul 16, 2016 3:13 pm
Forum: Technical Discussion
Topic: What script runs when you power on the board?
Replies: 5
Views: 3972

Re: What script runs when you power on the board?

The new OpenMV IDE preview is now available for Windows/Mac/Linux now. Windows: http://openmv.io/upload/openmv-ide-windows-1.0.0/openmv-ide-windows-1.0.0.exe Mac: http://openmv.io/upload/openmv-ide-mac-1.0.0/openmv-ide-mac-1.0.0.dmg Linux-32-bit: http://openmv.io/upload/openmv-ide-linux-x86-1.0.0/op...
by kwagyeman
Sat Jul 16, 2016 8:59 am
Forum: Technical Discussion
Topic: What script runs when you power on the board?
Replies: 5
Views: 3972

Re: What script runs when you power on the board?

Yep! Main.py is the script that runs on power on.

Oh, so we have a Mac Ide now. Please email me at the OpenMV email and I'll send you a link.
by kwagyeman
Sat Jul 16, 2016 8:57 am
Forum: Technical Discussion
Topic: WIFI Shield not working
Replies: 3
Views: 2913

Re: WIFI Shield not working

Hi, I'm not able to answer questions fully right now but I will try my best via my phone. The emboss script is failing because you need as SD card. I thin we need to add an assert if you try to save images without an SD card installed. As for the WiFi shield... You're the second person who's had a p...
by kwagyeman
Wed Jul 13, 2016 10:22 pm
Forum: Technical Discussion
Topic: MV primer?
Replies: 9
Views: 4969

Re: MV primer?

So, you pass find_blobs a size of color tuples - e.g: [ (l_min, l_max, a_min, a_max, b_min, b_max), (l_min, l_max, a_min, a_max, b_min, b_max), (l_min, l_max, a_min, a_max, b_min, b_max), ..., (l_min, l_max, a_min, a_max, b_min, b_max) ] The blobs returned from the find_blobs function have a color i...
by kwagyeman
Mon Jul 11, 2016 10:04 am
Forum: Technical Discussion
Topic: thermopile shield code
Replies: 15
Views: 6693

Re: thermopile shield code

Sigh... alright, we don't have QC on these modules since they are so simple. So, I guess something like this can happen. Please email openmv@openmv.io for what you'd like to do. I'm sorry the module is not working. We've tested our code out on 10 of them and haven't had any problems. Well, anyway, j...
by kwagyeman
Sun Jul 10, 2016 8:36 pm
Forum: General Topics
Topic: Getting Started Documentation Changes
Replies: 3
Views: 3369

Re: Getting Started Documentation Changes

There's an OpenMV docs repo you can post the issue too. Please see out github repos.
by kwagyeman
Sun Jul 10, 2016 12:52 am
Forum: General Topics
Topic: Getting Started Documentation Changes
Replies: 3
Views: 3369

Re: Getting Started Documentation Changes

Oh, yeah, that's probably, wrong. QVGA is 320x240. Thanks for the catch.
by kwagyeman
Sat Jul 09, 2016 5:27 pm
Forum: Technical Discussion
Topic: Can't get input capture to work.
Replies: 3
Views: 2923

Re: Can't get input capture to work.

Ibrahim will have to look into this for you. Our PYB support isn't the best. I've never tested the input capture modes.

Sorry about this.
by kwagyeman
Sat Jul 09, 2016 4:59 pm
Forum: Technical Discussion
Topic: Difficulties Connecting
Replies: 70
Views: 27629

Re: Difficulties Connecting

Alright, email us with your info and I'll send out another as a replacement next week.
by kwagyeman
Sat Jul 09, 2016 4:58 pm
Forum: Technical Discussion
Topic: thermopile shield code
Replies: 15
Views: 6693

Re: thermopile shield code

Hi, do you see any data moving on the wires? Do you have a protocol analyzer?

Do you have another I2C device? can you test out with that to verify the I2C bus works for another device? please remember at add plug up resistors.
by kwagyeman
Sat Jul 09, 2016 3:10 pm
Forum: Technical Discussion
Topic: Difficulties Connecting
Replies: 70
Views: 27629

Re: Difficulties Connecting

Okay, just try updating the firmware using this: https://github.com/openmv/openmv/wiki/Using-DFU-to-update-your-firmware Make sure to click the correct box when updating the firmware. >> To load the firmware image onto your OpenMV Cam open the DfuSe Demo application and click the Choose... button in...
by kwagyeman
Sat Jul 09, 2016 3:00 pm
Forum: Project Discussion
Topic: Line Following - Blob Spotting/Decoding robot
Replies: 42
Views: 22326

Re: Line Following - Blob Spotting/Decoding robot

Yep, you can always connect grounds to each other. In fact, you have to do this. That said, please connect the lipo (+) to the VIN pin on the OpenMV Cam. Anyway, this all said, 7.5 V sounds kinda high for the servos. Please make sure to check the voltage rating on the servos. As for the OpenMV Cam i...
by kwagyeman
Sat Jul 09, 2016 2:36 pm
Forum: Technical Discussion
Topic: Difficulties Connecting
Replies: 70
Views: 27629

Re: Difficulties Connecting

Oh, the Ide automatically finds the correct serial port for the cam. It will only ask if there are two cams connected. You don't have to worry about serial ports anymore with the new Ide. It filters serial ports by PID and VID so that only cam ports are considered.
by kwagyeman
Sat Jul 09, 2016 2:35 pm
Forum: Technical Discussion
Topic: Difficulties Connecting
Replies: 70
Views: 27629

Re: Difficulties Connecting

So, if you got a timeout error then that means the IDE was able to open a serial port on the board. Then it sent the firmware version command and got no response. So, the firmware on the cam is likely the problem.

Um, I'll post in a bit how to update the firmware if I haven't already.
by kwagyeman
Fri Jul 08, 2016 11:07 am
Forum: Technical Discussion
Topic: Difficulties Connecting
Replies: 70
Views: 27629

Re: Difficulties Connecting

The Cam behavior seems fine. Mmm, okay, well, when the IDE preview comes out give it a try.
by kwagyeman
Fri Jul 08, 2016 9:13 am
Forum: Technical Discussion
Topic: Difficulties Connecting
Replies: 70
Views: 27629

Re: Difficulties Connecting

I'll be posting a Kick Starter update with a link to the preview version of the new IDE for windows. I don't have all the bells and whistles complete yet. But, the serial connection is good and it's more or less usable. If the new IDE gives you problems then its either the firmware wasn't flashed ju...

Go to advanced search