Search found 74 matches

by mjs513
Wed Sep 19, 2018 3:05 pm
Forum: General Topics
Topic: Can't fined lenet.network or cifar10.network files
Replies: 4
Views: 2867

Re: Can't fined lenet.network or cifar10.network files

thanks will download the models and give it a try. Any place in particular to put them?
by mjs513
Wed Sep 19, 2018 11:52 am
Forum: General Topics
Topic: Can't fined lenet.network or cifar10.network files
Replies: 4
Views: 2867

Can't fined lenet.network or cifar10.network files

I just updated my ide to 2.0.0 and updated firmware as well. I went to run the nn_cfar10 and lenet examples and it gave me the error messages about not finding the file. I found it in explorer and gave it the whole path but it still complained. Any suggestions? Also just starting out with machine le...
by mjs513
Thu Sep 14, 2017 3:05 am
Forum: Technical Discussion
Topic: Newly bought Wifi Shield hanged
Replies: 12
Views: 4898

Re: Newly bought Wifi Shield hanged

I had a similar issue where the wifi shield would hang at trying to connect to the network. If this is the issue you are having try changing the port from 8080 to 80. You didn't really make it clear where it was hanging. Were you getting any messages printed - did the scan network sketch work? If no...
by mjs513
Mon Sep 11, 2017 8:23 am
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

I guess given a choice I would prefer the new method.
by mjs513
Sat Sep 09, 2017 9:03 am
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Yeah. That's what I thought would have to be done but just was curious if there was another way. As for replacing the old method with the new method. Not 100% sure. On one hand the new method is probably better at finding line segments as well as for me less variables to adjust but if there are a lo...
by mjs513
Fri Sep 08, 2017 9:03 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Hi K. Sorry for not posting sooner. I have been busy with a couple other projects. Anyway, I've been playing around with the function for a few days on and off now including using magnitude as a filter as well as looking lines only in the lower have of the screen. It does work nicely if there is suf...
by mjs513
Mon Sep 04, 2017 7:13 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

This is getting more interesting. I decided to print the line info and looked like there were more lines on the screen than there was line info, or it could just be timing for the print. Anyway, wanted to know if there was a way to access the individual line info that is printed: {x1:41, y1:67, x2:6...
by mjs513
Mon Sep 04, 2017 11:17 am
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Hi K. Started playing with it and yes it can be useful. Finding it interesting that it works a bit better in lower brightness (i used auto setting from my previous posts). The hard lines are much more consistent between frames. Going to play more tonight and tomorrow - getting ready for the party. M...
by mjs513
Sun Sep 03, 2017 10:31 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Hi Nyamekye, Can't tell you how much I appreciate the time you are spending on this. As to your question on speed vs accuracy. Isn't that always the issue. I know this may sound like a cope out but I think there is probably a break even point between the two, you want to kind of balance the two. In ...
by mjs513
Sun Sep 03, 2017 7:50 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Thanks for keeping me posted. Everything turns out to be more work than planned :). I created the pull request for the Autonomous Rover. Got a little carried away with the write up. Feel free to edit to your hearts content :)
by mjs513
Sat Sep 02, 2017 8:10 pm
Forum: Project Discussion
Topic: Obstacle Detection and Avoidance
Replies: 30
Views: 18259

Re: Obstacle Detection and Avoidance

Yep. Saw the donkey car so I figured it was the right one :).

9/3/17 = created pull request :)
by mjs513
Sat Sep 02, 2017 7:01 pm
Forum: Project Discussion
Topic: Obstacle Detection and Avoidance
Replies: 30
Views: 18259

Re: Obstacle Detection and Avoidance

Thank you. How detailed do you need the write up?
by mjs513
Sat Sep 02, 2017 1:19 pm
Forum: Project Discussion
Topic: Obstacle Detection and Avoidance
Replies: 30
Views: 18259

Re: Obstacle Detection and Avoidance

ok. Finally got everything at least baselined and tweaked to a point where it does work depending on a few factors I have to work on. I made a little video of it: https://photos.app.goo.gl/JIc3378SOzJR2bSn1 Cheers. PS> next version how about lots more memory and higher res camera :) know its a wish ...
by mjs513
Thu Aug 31, 2017 5:03 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Thanks man. No rush so please take you time.

Mike
by mjs513
Thu Aug 31, 2017 8:26 am
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

No. Not a line follower. I doing obstacle detection and avoidance, see http://forums.openmv.io/viewtopic.php?f=5&t=276 using a openmv camera and a single vl53 distance sensor. Depending on the lighting and contrast edges may or may not be detected. Got around the issue of changing detection values b...
by mjs513
Wed Aug 30, 2017 6:19 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Hey, I got a lot of progression on porting the lsd algorithm to the cam. Was wondering if you ever had a chance to finish the porting of the algorithm. Know you are all busy, but was just wondering. Still tweaking and testing the rover with the camera. Had a couple of good runs but not consistent.
by mjs513
Thu Aug 24, 2017 3:26 pm
Forum: Technical Discussion
Topic: WiFi not working I think?
Replies: 11
Views: 4886

Re: WiFi not working I think?

I couldn't in station mode. Once I changed to 80 I was able to connect. It must be something with my router settings. I have to check it eventually. Figured I would post if anyone else had a similar problem.

Thanks for your help.
by mjs513
Thu Aug 24, 2017 10:25 am
Forum: Technical Discussion
Topic: WiFi not working I think?
Replies: 11
Views: 4886

Re: WiFi not working I think?

Hi K. Thought I would give you a little more additional information on the config. But anyway, got it working. I was using the default port of 8080. I changed it to 80 and firefox connected no problem. Think the only issue is to improve the image quality and the be able to increase the image size wh...
by mjs513
Thu Aug 24, 2017 1:39 am
Forum: Technical Discussion
Topic: WiFi not working I think?
Replies: 11
Views: 4886

Re: WiFi not working I think?

DId just try on a Ubuntu virtual machine but no luck. I am running windows 10 64 bit version but I did have it up and running in Firefox a couple of months ago. Just as a fyi
by mjs513
Wed Aug 23, 2017 10:25 pm
Forum: Technical Discussion
Topic: WiFi not working I think?
Replies: 11
Views: 4886

Re: WiFi not working I think?

Ok. Got the new WiFi board and scan works fine, no issues. I can connect to the network no problem. But I am having problems with the Firefox browser. Keeps giving me unsecured network but when I do page info it does not allow me to change permissions. Tried Chrome, IE, and IE11. Any suggestions.
by mjs513
Sun Aug 20, 2017 9:00 am
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

kwagyeman - I started taking a closer look at the settings they are using for the different light modes. For other than direct sun light and night modes 3 of the register settings (0x65, 0x2e and 0x2d) are the same. That leaves only the Red and Blue gains being adjusted depending on lighting. If you...
by mjs513
Fri Aug 18, 2017 8:52 am
Forum: Technical Discussion
Topic: WiFi not working I think?
Replies: 11
Views: 4886

Re: WiFi not working I think?

Thanks. Must have blown the shield. Just ordered another one.
by mjs513
Thu Aug 17, 2017 8:09 pm
Forum: Technical Discussion
Topic: WiFi not working I think?
Replies: 11
Views: 4886

Re: WiFi not working I think?

Just tried it again and still not working.
by mjs513
Wed Aug 16, 2017 2:36 pm
Forum: Technical Discussion
Topic: WiFi not working I think?
Replies: 11
Views: 4886

WiFi not working I think?

Can not seem to get Wifi working with 2.5.0 release. I ran the scan.py script and it just hung. Just sits there waiting for something. Then tried to connect to my network and kept saying its waiting to connect. Not sure if it me or the hardware.

Thanks
Mike
by mjs513
Mon Aug 14, 2017 6:35 am
Forum: Technical Discussion
Topic: Power the M7 from a 3.3 reg
Replies: 2
Views: 1756

Re: Power the M7 from a 3.3 reg

Think I shorted something out, because the chip is getting really hot and wanted to know if that was normal.

EDIT: Took it out of the system and tried it just on usb, thing heated up right away. Just ordered a replacement from your site.
by mjs513
Sun Aug 13, 2017 7:35 pm
Forum: Technical Discussion
Topic: Power the M7 from a 3.3 reg
Replies: 2
Views: 1756

Power the M7 from a 3.3 reg

Hi. I have a rover that I am now powering the M7 from a 3.3v reg that goes into Vin, Gnd goes to gnd of the camera and the Teensy MCU that I am using to control the rover. The regulator is getting its power from the 7.4v lipo batter which also powers the rover electronics and the motors. Its working...
by mjs513
Sun Aug 13, 2017 9:04 am
Forum: General Topics
Topic: OpenMV IDE 1.7.0 / Firmware 2.5.0
Replies: 8
Views: 6815

Re: OpenMV IDE 1.7.0 / Firmware 2.5.0

Hi kwagyeman,

Just downloaded 1.7.1 and all is fine with the world :) Works like a charm, identified the outdated firmware version, uploaded fine to M7 and all the new examples are there.

Thanks
MIke
by mjs513
Sat Aug 12, 2017 11:47 pm
Forum: General Topics
Topic: OpenMV IDE 1.7.0 / Firmware 2.5.0
Replies: 8
Views: 6815

Re: OpenMV IDE 1.7.0 / Firmware 2.5.0

Hi kwagyeman,

Thought it was just me doing something wrong as usual. But anyway you intermediate build approach sounds good.

Thanks
Mike
by mjs513
Sat Aug 12, 2017 9:25 pm
Forum: General Topics
Topic: OpenMV IDE 1.7.0 / Firmware 2.5.0
Replies: 8
Views: 6815

Re: OpenMV IDE 1.7.0 / Firmware 2.5.0

So basically download from the GitHub, extract it to ide firmware folder for mv3 and then let the ide do the work. Got it. EDIT. I overwrote the firmware in the folder and also changed the firmware.txt file to read 2.5.0 but still showed 2.5.0 but I went ahead and uploaded it anyway. Figured it was ...
by mjs513
Sat Aug 12, 2017 9:12 pm
Forum: General Topics
Topic: OpenMV IDE 1.7.0 / Firmware 2.5.0
Replies: 8
Views: 6815

Re: OpenMV IDE 1.7.0 / Firmware 2.5.0

Thanks. But how do I install the firmware from the zip. Didn't see any reference in docs on how to do that. But then again, I probably just missed it. :)
by mjs513
Sat Aug 12, 2017 8:52 pm
Forum: General Topics
Topic: OpenMV IDE 1.7.0 / Firmware 2.5.0
Replies: 8
Views: 6815

OpenMV IDE 1.7.0 / Firmware 2.5.0

Just downloaded IDE 1.7.0 and seems to work fine. When I look at the release notes it says that it is updated for Firmware 2.5.0. However, when look at the bottom of the screen it shows that 2.4.1 is the latest version? Has 2.5.0 been released yet?
by mjs513
Fri Aug 11, 2017 10:28 am
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Nyamekye, I posted a couple of documents that you might find interesting on the omnivision cams in case you change the sensor: https://drive.google.com/open?id=0BwzZj ... GlhNTVUMkk
by mjs513
Fri Aug 11, 2017 8:40 am
Forum: Technical Discussion
Topic: Keyboard input
Replies: 3
Views: 2279

Re: Keyboard input

Thanks man. Didn't think so but just wanted to be sure. Wanted to be able to programmatically change options while still running the program.
by mjs513
Fri Aug 11, 2017 12:31 am
Forum: Technical Discussion
Topic: Keyboard input
Replies: 3
Views: 2279

Keyboard input

Hi. Was wondering if there was a way for a user to input commands from the keyboard with the openmv. I tried: try: mode=int(raw_input('Input:')) except ValueError: print "Not a number" but got an error on raw_input. Same thing here mport msvcrt def kbfunc(): x = msvcrt.kbhit() if x: ret = ord(msvcrt...
by mjs513
Thu Aug 10, 2017 6:33 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

I started playing around with the modes some more along with adjusting for banding. Here is a test sketch. May help. # Find Line Segments Example # # This example shows off how to find line segments in the image. For each line object # found in the image a line object is returned which includes the ...
by mjs513
Wed Aug 09, 2017 8:14 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Playing with lighting options: # Hello World Example # # Welcome to the OpenMV IDE! Click on the green run arrow button below to run the script! import sensor, image, time sensor.reset() # Reset and initialize the sensor. sensor.set_pixformat(sensor.RGB565) # Set pixel format to RGB565 (or GRAYSCALE...
by mjs513
Wed Aug 09, 2017 5:04 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

kwagyeman. You might find this document of use in your efforts. Found it doing a web search. Has some stuff I was looking into: http://www.electrodragon.com/w/images/4 ... n_note.pdf
by mjs513
Tue Aug 08, 2017 10:10 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Thanks kwagyeman. I am surprised that you decided to work on it. I have started to look at the register mapping and the settings. Quite a bit in there.
by mjs513
Sun Aug 06, 2017 2:08 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

I used sensor.set_auto_exposure(False, value=0) to turn the exposure off, unless its suppose to +1? Didn't notice that you were able to set the reg using a sensor command. Just looked it up now that you mentioned it.
by mjs513
Sun Aug 06, 2017 6:47 am
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Hi iabdalkader, EDIT: Ok turned them both off and screen went black. Seems to be driven by auto exposure. I did experiment a little bit and just used: sensor.set_auto_gain(False,value=0) sensor.set_gainceiling(2) It seemed to get better if the edges were very distinct. If there were any shadows it w...
by mjs513
Sat Aug 05, 2017 8:45 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Only got it just now because I got my rove semi working with the M7 and was looking for something more stable so I finally tried the line segments example and decided to post. Sorry about that. Anyway in looking for more info on 7725 registers I cam across the Arducam which is interesting since it c...
by mjs513
Sat Aug 05, 2017 8:05 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

Hi kwagyeman, Hmm. Thought there was a video embedded in the fist link that I sent you. I did notice that the histogram was jumping quite a bit which I thought might be a contributor but I didn't know how to stop that. I have tried changing the gain and brightness in the past but..... Now, looking a...
by mjs513
Sat Aug 05, 2017 4:27 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Re: Lines Detected Change on successive images

I am going to take a look at it. But for now is there a way to do it just on a single image?

Also have you seen this, looks interesting: http://www.ipol.im/pub/art/2012/gjmr-lsd/, https://github.com/primetang/LSD-OpenC ... ster/pylsd. Unfortunately looks like it wants numpy :(.
by mjs513
Sat Aug 05, 2017 2:15 pm
Forum: Technical Discussion
Topic: Lines Detected Change on successive images
Replies: 39
Views: 11479

Lines Detected Change on successive images

I am trying to understand the line-segment example that was added in the last release. It works rather well except for one thing. As I let it run the lines detected change in successive frames. They go back and forth between the lines. I made a little video of what I mean at this link, https://drive...
by mjs513
Wed Jun 14, 2017 4:38 pm
Forum: General Topics
Topic: openmv to arduino with template matching examples
Replies: 24
Views: 14969

Re: openmv to arduino with template matching examples

Not sure if you got this working, but recommend two things. Check that the baud rate on the Arduino matches the baudrate in your openmv sketch. I also added a slight delay after I send the characters to the Arduino.
by mjs513
Wed May 31, 2017 6:28 pm
Forum: Project Discussion
Topic: Obstacle Detection and Avoidance
Replies: 30
Views: 18259

Re: Obstacle Detection and Avoidance

Finally got the code working for at least some baseline testing. The final output that I am sending to a Teensy 3.5 over the uart is the estimated angle of perceived gaps. So anyway, thought I would share the code if anyone is interested (note: not the most efficient). There's also an option to send...
by mjs513
Tue May 23, 2017 7:39 am
Forum: Project Discussion
Topic: Obstacle Detection and Avoidance
Replies: 30
Views: 18259

Re: Obstacle Detection and Avoidance

Sorry for not getting back here sooner but am in the processes of putting together a test bot and tweaking the code some more. Yep, read up on it and for some dumb reason thought the fast basic one was using canny as well. Think my eyes were getting crossed. By the way I also tested sending data ove...
by mjs513
Tue May 23, 2017 7:36 am
Forum: Project Discussion
Topic: Real Time Streaming and Speed
Replies: 9
Views: 7803

Re: Real Time Streaming and Speed

Hi Riche Been playing around with the advanced script a bit for motion detection, or for me, no motion if a bot gets stuck. Anyway, I used the advanced script but changed to gray scale the image instead of color, and right after the img.difference statement I added these lines: if img.get_statistics...
by mjs513
Mon May 15, 2017 8:32 pm
Forum: Project Discussion
Topic: Obstacle Detection and Avoidance
Replies: 30
Views: 18259

Re: Obstacle Detection and Avoidance

Thanks appreciate it. I actually have another question. When I run the edge detection example it shows the edge of the frame as a detected edge. How do you get around that?

Go to advanced search