Page 1 of 1

frame reading

Posted: Sun Oct 07, 2018 1:22 am
by rajeshktym
I m trying to read frame through above code but size always shows (0, 1162563860, 1171345940) this, any idea why I m not getting jpeg frame?

Re: frame reading

Posted: Sun Oct 07, 2018 2:12 am
by kwagyeman
That's a garbage frame. If the first value is 0 then you need to keep reading until you get a non-zero first value. Then the frame is ready.

Re: frame reading

Posted: Sun Oct 07, 2018 8:32 pm
by rajeshktym
yes sir, I m trying to get non zero as first value, but it always give 0, what could be reason? where I can check?

Re: frame reading

Posted: Mon Oct 08, 2018 3:05 am
by kwagyeman
Um, a script needs to be running on the camera that calls snapshot. Can you verify the script is running?

Re: frame reading

Posted: Mon Oct 08, 2018 6:27 am
by rajeshktym
script included in my python code and I m executing beginning, can u please see my code? if u can suggest some thing will be gr8 help

Re: frame reading

Posted: Mon Oct 08, 2018 11:51 pm
by kwagyeman
Can you start with this script?

https://github.com/openmv/openmv/blob/m ... enmv_fb.py

You've edited our code heavily...

Re: frame reading

Posted: Wed Oct 10, 2018 6:41 pm
by rajeshktym
Yes Sir, I referred and made it from your library only, trying to convert it as stand alone sensor. your sample code is working with module. but simplified my code is not working, that I m trying to solve and looking for any help..

Re: frame reading

Posted: Thu Oct 11, 2018 12:24 am
by kwagyeman
Um, so, just go back to our code and just ignore parts you don't need... you don't have to modify the code if you don't need to.

I tried your script out and could confirm it's not working. But, I really can't do hands on debug support anymore. Too many people are asking for my time now.

Re: frame reading

Posted: Thu Oct 11, 2018 5:09 am
by rajeshktym
I understand sir, thanks for ur support, thought some members tried the same and may get some help