WiFi Shield Socket - No Bytes Read

Discussion related to "under the hood" OpenMV topics.
thomas_newman
Posts: 2
Joined: Fri May 11, 2018 12:05 pm

WiFi Shield Socket - No Bytes Read

Postby thomas_newman » Fri May 11, 2018 12:15 pm

I am attempting to run the TCP Client sample that comes with the OpenMV IDE. I am able to successfully connect to my wifi network, but the socket returns 0 bytes on read. I have tested this with a few wifi networks. I have OpenMV V3 and ATWINC1500-MR210PB with the latest firmware.

Here is the code:
tcp_client_1.py
(812 Bytes) Downloaded 18 times
User avatar
kwagyeman
Posts: 2312
Joined: Sun May 24, 2015 2:10 pm

Re: WiFi Shield Socket - No Bytes Read

Postby kwagyeman » Sun May 13, 2018 3:10 pm

Hi, I've asked Ibrahim to take a look at this.
Nyamekye,
User avatar
iabdalkader
Posts: 552
Joined: Sun May 24, 2015 3:53 pm

Re: WiFi Shield Socket - No Bytes Read

Postby iabdalkader » Mon May 14, 2018 8:54 pm

Hi, there was a bug in the recently updated sockets layer. I'm attaching a patched fw image if you want to use it now.
Note re that example script, the buffer size passed to recv should be large enough to hold the received data (otherwise it gets overwritten).
Attachments
firmware.zip
(1.07 MiB) Downloaded 17 times
thomas_newman
Posts: 2
Joined: Fri May 11, 2018 12:05 pm

Re: WiFi Shield Socket - No Bytes Read

Postby thomas_newman » Thu May 17, 2018 8:35 am

The updated firmware worked. Thank you for your help!

Return to “Technical Discussion”

Who is online

Users browsing this forum: No registered users and 4 guests