Page 1 of 1

AttributeError: 'module' object has no attribute 'alloc_extra_fb'

Posted: Wed Jan 24, 2018 9:10 pm
by sig_UVa78
Hello,

I received the error in the subject link when I ran the 20-Frame-Differencing example openmv/usr/examples/20-Frame-Differenci ... rencing.py. The program halts at line 24.

Anything I can do to fix this? I couldn't find the error on the forums.

Thanks for your help. Cool product so far, but I am a noob, so I'm stumbling through.

Re: AttributeError: 'module' object has no attribute 'alloc_extra_fb'

Posted: Wed Jan 24, 2018 9:25 pm
by kwagyeman
You need to install the latest firmware which was just released. It's not packaged for download yet though. See the release tab on the OpenMV GitHub.

Re: AttributeError: 'module' object has no attribute 'alloc_extra_fb'

Posted: Wed Jan 24, 2018 9:52 pm
by sig_UVa78
Thank you. I am not sure what you mean by Release tab though.

I found this folder: https://github.com/openmv/openmv/tree/master/firmware

Would I still be able to use the IDE to update the firmware or can it only be done manually?

OPENMV4 folder?

Thanks!

Re: AttributeError: 'module' object has no attribute 'alloc_extra_fb'

Posted: Wed Jan 24, 2018 10:11 pm
by kwagyeman
https://github.com/openmv/openmv/releases

Use either the firmware.bin or OpenMV.dfu file in the OPENMV3 folder. You can use the IDE to update the camera.

Re: AttributeError: 'module' object has no attribute 'alloc_extra_fb'

Posted: Thu Jan 25, 2018 9:30 pm
by sig_UVa78
So I downloaded those files. However in the IDE, I can't seem to force it to ask for the DFU.

I read in the hardware setup tutorial that it would prompt me to do so, but my firmware is also up-to-date with 2.6.0 (according the IDE). It does ask me if I want to reset to the release version, but that didn't seem to go well. I'm still at 2.6.0.

Thanks for your patience!

Re: AttributeError: 'module' object has no attribute 'alloc_extra_fb'

Posted: Fri Jan 26, 2018 12:47 am
by kwagyeman
See Tools->Run bootloader.

Re: AttributeError: 'module' object has no attribute 'alloc_extra_fb'

Posted: Fri Jan 26, 2018 9:17 pm
by sig_UVa78
That worked. Thank you!

Re: AttributeError: 'module' object has no attribute 'alloc_extra_fb'

Posted: Mon Feb 12, 2018 12:03 pm
by Nando
Hi kwagyeman,

I've run across the same 'alloc_extra_fb' problem trying to use one of the examples on your github, https://github.com/kwagyeman/openmv/blo ... calflow.py

Is the OPENMV3 folder for the OpenMV M7 cam?
I was looking at the old firmwares, and for example firmware 2.0 has a clear "OPENMV7" folder.

Re: AttributeError: 'module' object has no attribute 'alloc_extra_fb'

Posted: Mon Feb 12, 2018 12:30 pm
by kwagyeman
OpenMV 3 is the OpenMV Cam M7. OpenMV 2 is the M4 board, 1 is the oldest OpenMV Cam from 2013 that was never sold commerically. 4 is the upcoming H7 model.

Re: AttributeError: 'module' object has no attribute 'alloc_extra_fb'

Posted: Mon Feb 12, 2018 1:18 pm
by Nando
Thank you very much.
The update and python code on the openmv worked right away. Now to get the whole thing working.