Can't Connect M& Open MV Cam(STM32F765)

Discussion related to "under the hood" OpenMV topics.
westmi
Posts: 10
Joined: Fri Sep 01, 2017 5:26 pm

Can't Connect M& Open MV Cam(STM32F765)

Postby westmi » Fri Sep 01, 2017 5:48 pm

I currently own a UARM Swift Pro pick and place unit and I can't get the M7 camera to be recognized by the Arduino Mega 2560 board. I have tried everything to get the camera to be recognized by the board but to no avail (Hit connect button, don't erase internal file reboot, erase internal file reboot, jumper out boot to RS, Stand on my head, etc) The camera has power and the blue light is blinking, for whatever reason it just won't recognize the camera. The manual calls for the connectors to be P5 to RX2 on Arduino, P4 to TX2 on arduino, ground to ground, VIN to 5V. I have Open MV version IDE is 1.7.1, and have no idea what version firmware I have for Open MV CAm (STM32F765). Can you help. I am a novice at this stuff, so please be patient.
User avatar
kwagyeman
Posts: 1175
Joined: Sun May 24, 2015 2:10 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby kwagyeman » Fri Sep 01, 2017 8:01 pm

Hi, since the camera can connect form the IDE it's probably fine. Um, can you go to examples, basics, and click on the UART example script and verify that you see serial data coming out of the camera when you run that script? If you have a serial LCD screen or FTDI programmer you should be able to see the serial traffic. Probably and led would also let you know on the pin that some data is being sent over it. Please let me know what you find out.
Nyamekye,
westmi
Posts: 10
Joined: Fri Sep 01, 2017 5:26 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby westmi » Sat Sep 02, 2017 7:46 am

Video of what is happening

https://photos.app.goo.gl/QRmdg8PCg0byr1yr2

I clicked file/examples/basic and only files there are hello world.py and basic.py.
User avatar
kwagyeman
Posts: 1175
Joined: Sun May 24, 2015 2:10 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby kwagyeman » Sat Sep 02, 2017 12:04 pm

Sorry, um, I meant to say board control. It's under the second examples folder.
Nyamekye,
westmi
Posts: 10
Joined: Fri Sep 01, 2017 5:26 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby westmi » Sat Sep 02, 2017 1:24 pm

All I see is this script with no reference to a serial monitor in Open Mv software or how to upload this script.

UART Control
#
# This example shows how to use the serial port on your OpenMV Cam. Attach pin
# P4 to the serial input of a serial LCD screen to see "Hello World!" printed
# on the serial LCD display.

import time
from pyb import UART

# Always pass UART 3 for the UART number for your OpenMV Cam.
# The second argument is the UART baud rate. For a more advanced UART control
# example see the BLE-Shield driver.
uart = UART(3, 19200)

while(True):
uart.write("Hello World!\r")
time.sleep(1000)
User avatar
kwagyeman
Posts: 1175
Joined: Sun May 24, 2015 2:10 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby kwagyeman » Sat Sep 02, 2017 3:50 pm

Once the script is open you just click the green run button and it will execute. Afterwards, you should see some serial data on the TX pin of your OpenMV Cam. Pin 4.

? Since the blue LED was blinking on your OpenMV cam originally you probably just need to copy the script that uARM gave you to the OpenMV Cam, call that script main.py, and then safety remove the OpenMV Cam from your PC and you should be operational.
Nyamekye,
westmi
Posts: 10
Joined: Fri Sep 01, 2017 5:26 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby westmi » Sat Sep 02, 2017 5:37 pm

Green button is greyed out for both programs, showing not active. I must have power to the card but not communicating. The connectors have continuity to the pins, Currently have RT/D17 pin to camera pin p4, and TX2/d16 pin to camera P5. is this correct.
User avatar
kwagyeman
Posts: 1175
Joined: Sun May 24, 2015 2:10 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby kwagyeman » Sat Sep 02, 2017 5:56 pm

Hi, did you hit the connect button? It's right above the green button. You have to hit that to connect to the camera. It looks like a picture of a plug jack. Once you press it you should be able to run programs.
Nyamekye,
westmi
Posts: 10
Joined: Fri Sep 01, 2017 5:26 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby westmi » Sat Sep 02, 2017 7:30 pm

no open MV camera found error message pops up
User avatar
kwagyeman
Posts: 1175
Joined: Sun May 24, 2015 2:10 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby kwagyeman » Sat Sep 02, 2017 7:52 pm

I see. Okay, can you let me know what OS are you using and if you are connected to the OpenMV cam with a USB cable that has data and power? There are a lot of power only USB cables out there which won't work for allowing you camera to communicate to the PC. Please verify the USB cable is useable by trying to connect your phone using the cable to your PC. If that works then the cable is good. If not then please use another USB cable.
Nyamekye,
westmi
Posts: 10
Joined: Fri Sep 01, 2017 5:26 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby westmi » Sat Sep 02, 2017 8:07 pm

I see. Okay, can you let me know what OS are you using and if you are connected to the OpenMV cam with a USB cable that has data and power? There are a lot of power only USB cables out there which won't work for allowing you camera to communicate to the PC. Please verify the USB cable is useable by trying to connect your phone using the cable to your PC. If that works then the cable is good. If not then please use another USB cable

Using Windows 10 I can power the camera connected directly to my computer (thus the blinking light). I can connect with my phone. The cable is fine I was using the same cable earlier to communicate with the robot. Everything stopped functioning correctly in my efforts to get the camera to run.
User avatar
kwagyeman
Posts: 1175
Joined: Sun May 24, 2015 2:10 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby kwagyeman » Sat Sep 02, 2017 8:25 pm

Okay, I don't think the camera is broken. It sounds fine from what you've said. However, I can issue a replacement if you like. Please email us to get this going.

...

Assuming the installer installed drivers and whatnot without any issues you should be up and running. Not sure what's wrong.
Nyamekye,
westmi
Posts: 10
Joined: Fri Sep 01, 2017 5:26 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby westmi » Sat Sep 02, 2017 9:04 pm

I will let you know. Let me work with the supplier of the robot first.

Thank you
westmi
Posts: 10
Joined: Fri Sep 01, 2017 5:26 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby westmi » Mon Sep 04, 2017 8:12 am

I have an Arduino Uno that I am going to connect the camera to. Can you please advise what program to load on my arduino to see objects in the open mv IDE. Please point me in the right direction to read and understand this so I can accomplish the task. I want to verify that the camera is fine.

Thank You
User avatar
kwagyeman
Posts: 1175
Joined: Sun May 24, 2015 2:10 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby kwagyeman » Mon Sep 04, 2017 2:19 pm

Hi, I think we need to solve why OpenMV IDE isn't connecting to your OpenMV Cam first. From the blue LED blinking on the Cam this means that it's fine. So, the question is... why doesn't the "connect" button on OpenMV IDE find the OpenMV Cam. Can you try OpenMV IDE on another computer? Also, do you notice a USB flash drive appearing when you plug your OpenMV Cam in? If you don't see an about 96KB USB flash drive appearing after the camera is plugged into your PC and the USB cable... is known to be good for transferring data... then the problem is that the D+/D- pins on the USB connector on the OpenMV Cam must be bad and you need a new camera. If this is the case I will issue you a replacement OpenMV Cam.
Nyamekye,
westmi
Posts: 10
Joined: Fri Sep 01, 2017 5:26 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby westmi » Tue Sep 05, 2017 6:34 am

I tried two computers already and two different make Areduino's. I guess the camera is bad. Here is my personal email address westmi@comcast.net
westmi
Posts: 10
Joined: Fri Sep 01, 2017 5:26 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby westmi » Tue Sep 05, 2017 8:59 pm

Nyamekye,
I got the camera to work today. The manufacturer of the robot advised me to:

Hi westmi, checked the video, the biggest problem is you didn't connect the openmv to PC with USB cable. OpenMV can only be recognized when being connected directly to PC. The connection with robot arm is a demo which makes the openmv and robot work together without the computer.
So the correct step is 1,connect the openmv to PC directly and download the tracking.py in openmv IDE successfully; 2,disconnect the openmv with PC and connect it with robot like your video shows (now the openmv cannot be detected by PC); 3,plug in the USB of robot and power supply, then turn on the switch; 4,send the command as the quick start guide said; 5,the rbot moves up and tracks the objects in camera.

Ok now that is done. Where can I read up on all the examples you provided in the OpenMV IDE so I can understand there functions.
User avatar
kwagyeman
Posts: 1175
Joined: Sun May 24, 2015 2:10 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby kwagyeman » Tue Sep 05, 2017 9:37 pm

Glad you got it working. Let me know if you need anything else. :)
Nyamekye,
User avatar
iabdalkader
Posts: 363
Joined: Sun May 24, 2015 3:53 pm

Re: Can't Connect M& Open MV Cam(STM32F765)

Postby iabdalkader » Tue Sep 05, 2017 9:43 pm

westmi wrote:
Tue Sep 05, 2017 8:59 pm
Ok now that is done. Where can I read up on all the examples you provided in the OpenMV IDE so I can understand there functions.
Untitled.png
Untitled.png (176.97 KiB) Viewed 470 times

Return to “Technical Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest